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Actualización más reciente 2023-11-20 GMT+08:00

ALM-24004 Flume no puede leer datos (para MRS 2.x o anterior)

Descripción

El módulo de alarma monitorea el estado de Flume source. Esta alarma se genera si la duración en la que Flume Source no puede leer los datos excede el umbral.

Los usuarios pueden modificar el umbral según sea necesario.

Esta alarma se borra si Source lee los datos correctamente.

Atributo

ID de alarma

Severidad de alarma

Borrar automáticamente

24004

Grave

Parámetros

Parámetro

Descripción

ServiceName

Especifica el servicio para el que se genera la alarma.

HostName

Especifica el host para el que se genera la alarma.

ComponentType

Especifica el tipo de componente para el que se genera la alarma.

ComponentName

Especifica el nombre del componente para el que se genera la alarma.

Impacto en el sistema

Se detiene la recopilación de datos.

Causas posibles

  • Flume source está defectuosa.
  • La red está defectuosa.

Procedimiento

  1. Compruebe si Flume Source es normal.

    1. Compruebe si Flume Source es el tipo spoolDir.
      • En caso afirmativo, vaya a 1.b.
      • Si no, vaya a 1.c.
    2. Consulte el directorio spoolDir y compruebe si se han enviado todos los archivos.
      • En caso afirmativo, no es necesario hacer nada más.
      • Si no, vaya a 1.e.
    3. Compruebe si la fuente de Flume es el tipo Kafka.
      • En caso afirmativo, vaya a 1.d.
      • Si no, vaya a 1.e.
    4. Inicie sesión en el cliente de Kafka y ejecute los siguientes comandos para comprobar si se han consumido todos los datos del topic configurados para Kafka Source.

      cd /opt/client/Kafka/kafka/bin

      ./kafka-consumer-groups.sh --bootstrap-server Kafka cluster IP address:21007 --new-consumer --describe --group example-group1 --command-config

      ../config/consumer.properties
      • En caso afirmativo, no es necesario hacer nada más.
      • Si no, vaya a 1.e.
    5. Vaya a la página de detalles del clúster y haga clic en Components.
    6. Elija Flume > Instances.
    7. Haga clic en la instancia Flume del nodo defectuoso y compruebe si el valor del Source Speed Metrics es 0.
      • En caso afirmativo, vaya a 2.a.
      • En caso negativo, no se requiere ninguna otra acción.

  2. Compruebe el estado de la red entre la fuente de Flume y el nodo defectuoso.

    1. Compruebe si la fuente de Flume es el tipo avro.
      • En caso afirmativo, vaya a 2.c.
      • Si no, vaya a 3.
    2. Inicie sesión en el host donde reside el nodo defectuoso. Ejecute el siguiente comando para cambiar a usuario root:

      sudo su - root

    3. Ejecute el comando ping Flume source IP address para comprobar si se puede hacer un ping al Flume Source.
      • En caso afirmativo, vaya a 3.
      • Si no, vaya a 2.d.
    4. Póngase en contacto con el administrador de red para reparar la red.
    5. Espere un rato y compruebe si la alarma está desactivada.
      • En caso afirmativo, no es necesario hacer nada más.
      • Si no, vaya a 3.

  3. Recopile información de fallas.

    1. En MRS Manager, seleccione System > Export Log.
    2. Póngase en contacto con el personal de O&M y envíe los registros recopilados.

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