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Actualización más reciente 2023-11-20 GMT+08:00

ALM-12043 La duración de análisis de DNS supera el umbral (Para MRS 2.x o anterior)

Descripción

El sistema comprueba la duración del análisis de DNS cada 30 segundos. Esta alarma se genera cuando la duración del análisis DNS excede el umbral (el umbral predeterminado es 20,000 ms) varias veces (el valor predeterminado es 2).

Puede cambiar el umbral seleccionando System > Threshold Configuration > Device > Host > Network Status > DNS Resolution Duration > DNS Resolution Duration.

Esta alarma se borra cuando hit number es 1 y la duración de la resolución de DNS es menor o igual que el umbral. Esta alarma se borra cuando hit number no es 1 y la duración de la resolución DNS es menor o igual al 90% del umbral.

Atributo

ID de alarma

Severidad de alarma

Borrar automáticamente

12043

Grave

Parámetros

Parámetro

Descripción

ServiceName

Especifica el servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

HostName

Especifica el host para el que se genera la alarma.

Impacto en el sistema

  • La autenticación secundaria basada en Kerberos es lenta.
  • El servicio ZooKeeper es anormal.
  • El nodo está defectuoso.

Causas posibles

  • El nodo se configura con el cliente de DNS.
  • El nodo está equipado con el servidor DNS y se inicia el servidor DNS.

Procedimiento

Compruebe si el nodo está configurado con el cliente de DNS.

  1. Vaya a la página de detalles del clúster de MRS y elija Alarms.
  2. Vea los detalles de la alarma para obtener el valor del campo HostName en Location.
  3. Utilice PuTTY para iniciar sesión en el nodo para el que se genera la alarma como usuario root.
  4. Ejecute el comando cat /etc/resolv.conf para comprobar si el cliente DNS está instalado.

    Si se muestra información similar a la siguiente, se instala e inicia el cliente DNS:

    namesever 10.2.3.4  
    namesever 10.2.3.4
    • En caso afirmativo, vaya a 5.
    • Si no, vaya a 7.

  5. Ejecute el comando vi /etc/resolv.conf para comentar el siguiente contenido usando los signos numéricos (#) y guarde el archivo:

    # namesever 10.2.3.4  
    # namesever 10.2.3.4

  6. Compruebe si esta alarma se borra después de 5 minutos.

    • En caso afirmativo, no es necesario hacer nada más.
    • Si no, vaya a 7.

Compruebe si el nodo está equipado con el servidor DNS y si el servidor DNS está iniciado.

  1. Ejecute el comando service named status para comprobar si el servicio DNS está instalado en el nodo.

    Si se muestra información similar a la siguiente, se instala e inicia el servidor DNS:

    Checking for nameserver BIND  
    version: 9.6-ESV-R7-P4 
    CPUs found: 8 
    worker threads: 8 
    number of zones: 17 
    debug level: 0 
    xfers running: 0 
    xfers deferred: 0 
    soa queries in progress: 0 
    query logging is ON 
    recursive clients: 4/0/1000 
    tcp clients: 0/100 
    server is up and running
    • En caso afirmativo, vaya a 8.
    • Si no, vaya a 10.

  2. Ejecute el comando service named stop para detener el servidor DNS.
  3. Compruebe si esta alarma se borra después de 5 minutos.

    • En caso afirmativo, no es necesario hacer nada más.
    • Si no, vaya a 10.

  4. Recopilar información de fallas.

    1. En MRS Manager, seleccione System > Export Log.
    2. Póngase en contacto con el personal de O&M y envíe los registros recopilados.

Referencia

Ninguna