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Actualización más reciente 2023-11-20 GMT+08:00

ALM-12028 Número de procesos en el Estado D en el host supera el umbral (Para MRS 2.x o anterior)

Descripción

El sistema comprueba periódicamente el número de procesos de estado D de usuario omm en el host cada 30 segundos y compara el número con el umbral. El número de procesos en el estado D en el host tiene un umbral predeterminado. Esta alarma se genera cuando el número de procesos en el estado D supera el umbral.

Esta alarma se borra cuando el número es menor o igual que el umbral.

Atributo

ID de alarma

Severidad de alarma

Borrar automáticamente

12028

Grave

Parámetros

Parámetro

Descripción

ServiceName

Especifica el servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

HostName

Especifica el host para el que se genera la alarma.

Trigger Condition

Genera una alarma cuando el valor real del indicador excede el umbral especificado.

Impacto en el sistema

Se utilizan recursos excesivos del sistema y el proceso de servicio responde lentamente.

Causas posibles

El host responde lentamente a las solicitudes de E/S (E/S de disco y E/S de red) y un proceso está en el estado D.

Procedimiento

  1. Compruebe el proceso que está en el estado D.

    1. Vaya a la página de detalles del clúster de MRS. En la lista de alarmas de la página de pestaña de gestión de alarmas, haga clic en la fila que contiene la alarma. En los detalles de la alarma, vea la dirección del host.
    2. Inicie sesión en el nodo para el que se genera la alarma.
    3. Ejecute los siguientes comandos para cambiar el usuario:

      sudo su - root

      su - omm

    4. Ejecute el siguiente comando como usuario omm para ver el PID del proceso que está en estado D:

      ps -elf | grep -v "\[thread_checkio\]" | awk 'NR!=1 {print $2, $3, $4}' | grep omm | awk -F' ' '{print $1, $3}' | grep D | awk '{print $2}'

    5. Compruebe si la salida del comando está vacía.
      • En caso afirmativo, el proceso de servicio se está ejecutando correctamente. Entonces vaya a 1.g.
      • Si no, vaya a 1.f.
    6. Cambie a usuario root y ejecute el comando reboot para reiniciar el host de alarma.

      Reiniciar el host conlleva ciertos riesgos. Asegúrese de que el proceso de servicio se ejecuta correctamente después del reinicio.

    7. Espere 5 minutos y compruebe si la alarma está desactivada.
      • En caso afirmativo, no es necesario hacer nada más.
      • Si no, vaya a 2.

  2. Recopilar información de fallas.

    1. En MRS Manager, seleccione System > Export Log.
    2. Póngase en contacto con el personal de O&M y envíe los registros recopilados.

Referencia

Ninguna