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Actualización más reciente 2023-11-20 GMT+08:00

ALM-12027 El uso de PID de host supera el umbral (para MRS 2.x o anterior)

Descripción

El sistema comprueba el uso del PID cada 30 segundos y compara el uso real del PID con el umbral predeterminado. Esta alarma se genera cuando el uso del PID excede el umbral.

Esta alarma se borra cuando el uso del PID del host es menor o igual que el umbral.

Atributo

ID de alarma

Gravedad de alarma

Borrar automáticamente

12027

Grave

Parámetros

Parámetro

Descripción

ServiceName

Especifica el servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

HostName

Especifica el host para el que se genera la alarma.

Trigger Condition

Genera una alarma cuando el valor real del indicador excede el umbral especificado.

Impacto en el sistema

No hay ningún PID disponible para los nuevos procesos y los procesos de servicio no están disponibles.

Causas posibles

Se están ejecutando demasiados procesos en el nodo. Necesita aumentar el valor de pid_max. El sistema no funciona normalmente.

Procedimiento

  1. Aumenta el valor de pid_max.

    1. En la página de detalles del clúster MRS, haga clic en la alarma de la lista de alarmas en tiempo real. En el área Alarm Details, obtenga la dirección IP del host para el que se genera la alarma.
    2. Inicie sesión en el nodo para el que se genera la alarma.
    3. Ejecute el comando cat /proc/sys/kernel/pid_max para comprobar el valor de pid_max.
    4. Si el uso de PID excede el umbral, ejecute el siguiente comando para duplicar el valor de pid_max:

      echo New pid_max value > /proc/sys/kernel/pid_max

      Ejemplo:

      echo 65536 > /proc/sys/kernel/pid_max

      El valor máximo de pid_max es el siguiente:

      • 32-bit OS: 32768
      • 64-bit OS: 4194304 (22nd power of 2)
    5. Espere 5 minutos y compruebe si la alarma está desactivada.
      • En caso afirmativo, no es necesario hacer nada más.
      • Si no, vaya a 2.

  2. Compruebe si el entorno del sistema es anormal.

    1. Póngase en contacto con el personal de O&M para comprobar si el sistema operativo es anormal.
      • En caso afirmativo, rectifique la falla del sistema operativo y vaya a 2.b.
      • Si no, vaya a 3.
    2. Espere 5 minutos y compruebe si la alarma está desactivada.
      • En caso afirmativo, no es necesario hacer nada más.
      • Si no, vaya a 3.

  3. Recopilar información de fallas.

    1. En MRS Manager, seleccione System > Export Log.
    2. Póngase en contacto con el personal de O&M y envíe los registros recopilados.

Referencia

Ninguna