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Actualización más reciente 2023-11-20 GMT+08:00

ALM-12014 Partición de dispositivo perdida (Para MRS 2.x o anterior)

Descripción

Esta alarma se genera cuando el sistema detecta que se ha perdido una partición en la que se montan los directorios de servicio (porque el dispositivo se quita o se desconecta, o la partición se elimina). El sistema comprueba periódicamente el estado de la partición.

Esta alarma necesita ser borrada manualmente.

Atributo

ID de alarma

Severidad de alarma

Borrar automáticamente

12014

Grave

No

Parámetros

Parámetro

Descripción

ServiceName

Especifica el servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

HostName

Especifica el host para el que se genera la alarma.

DirName

Especifica el directorio para el que se genera la alarma.

PartitionName

Especifica la partición de dispositivo para la que se genera la alarma.

Impacto en el sistema

Los datos de servicio no se pueden escribir en la partición y el sistema de servicio se ejecuta de forma anormal.

Causas posibles

  • Se quita el disco.
  • El disco está sin conexión o existe un sector defectuoso en el disco.

Procedimiento

  1. Vaya a la página de detalles del clúster de MRS y elija Alarms.
  2. En la lista de alarmas en tiempo real, haga clic en la fila que contiene la alarma.
  3. En el área Alarm Details, obtenga los valores de HostName, PartitionName y DirName de Location.
  4. Compruebe si el disco correspondiente a PartitionName de HostName está insertado en la ranura del servidor correcta.

    • En caso afirmativo, vaya a 5.
    • Si no, vaya a 6.

  5. Póngase en contacto con los ingenieros de hardware para quitar el disco defectuoso.
  6. Utilice PuTTY para iniciar sesión en el nodo HostName donde se reporta una alarma y verifique si hay una línea que contenga DirName en el archivo /etc/fstab.

    • En caso afirmativo, vaya a 7.
    • Si no, vaya a 8.

  7. Ejecute el comando vi /etc/fstab para editar el archivo y eliminar la línea que contiene DirName.
  8. Póngase en contacto con los ingenieros de hardware para insertar un nuevo disco. Para obtener más información, consulte el documento del producto de hardware del modelo correspondiente. Si el disco defectuoso está en un grupo RAID, configure el grupo RAID. Para obtener más información, consulte los métodos de configuración de la tarjeta controladora de RAID relevante.
  9. Espere de 20 a 30 minutos (el tamaño del disco determina el tiempo de espera) y ejecute el comando mount para comprobar si el disco se ha montado en el directorio DirName.

    • En caso afirmativo, borre la alarma manualmente. No se requiere ninguna operación adicional.
    • Si no, vaya a 10.

  10. Recopilar información de fallas.

    1. En MRS Manager, seleccione System > Export Log.
    2. Póngase en contacto con el personal de O&M y envíe los registros recopilados.

Referencia

Ninguna