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Centro de ayuda/ MapReduce Service/ Guía del usuario/ Referencia de alarma (aplicable a MRS 3.x)/ ALM-45617 Los datos en cola en la ranura de replicación CDL superan el umbral

ALM-45617 Los datos en cola en la ranura de replicación CDL superan el umbral

Actualización más reciente 2023-11-20 GMT+08:00

Descripción

Si un gran número de registros de escritura anticipada (WAL) se apilan en la base de datos de PostgreSQL, el espacio de disco PostgreSQL puede ser utilizado. El sistema comprueba si la cantidad de datos en cola en la ranura de replicación configurada para un trabajo de CDL excede el umbral cada 5 minutos. Esta alarma se genera cuando la cantidad de datos en cola en la ranura de replicación excede el umbral. Esta alarma se borra cuando el número de datos en cola en la ranura de replicación cae por debajo del umbral.

Atributo

ID de alarma

Severidad de alarma

Borrar automáticamente

45617

Grave

Parámetros

Nombre

Significado

Source

Especifica el clúster para el que se genera la alarma.

ServiceName

Especifica el servicio para el que se genera la alarma.

JobName

Especifica el trabajo para el que se genera la alarma.

DBName

Especifica la base de datos para la que se genera la alarma.

SlotName

Especifica la ranura de replicación de la base de datos para la que se genera la alarma.

Lag

Especifica los datos en cola en la ranura.

Impacto en el sistema

Los WAL se acumulan continuamente en la base de datos PostgreSQL de origen, lo que provoca que se agote el espacio en disco de la base de datos de origen.

Causas posibles

El trabajo de CDL es anormal y el procesamiento de datos se detiene; la base de datos de origen se actualiza rápidamente y el procesamiento de datos de CDL es lento.

Procedimiento

  1. Inicie sesión en FusionInsight Manager como un usuario que tiene el permiso de creación de trabajos de CDL o administrador.
  2. Elija O&M. En el panel de navegación de la izquierda, elija Alarm > Alarms, haga clic en en la fila donde Alarm ID es 45617, y vea el nombre del trabajo para el que se genera esta alarma en Location.
  3. Compruebe si aparece ALM-45616 CDL Job Execution Exception en la lista de alarmas.

    • En caso afirmativo, maneje la alarma realizando las operaciones previstas para el ALM-45616 Excepción de ejecución de trabajo CDL.
    • Si no, vaya a 4.

  4. Elija Cluster >Services >CDL. Haga clic en el enlace junto a CDLService UI para ir a la interfaz de usuario web de CDL y comprobar si el trabajo se muestra en la lista de trabajos basándose en su nombre obtenido en 2.

    • En caso afirmativo, verifique si el trabajo es anormal.
      • Si es anormal, vaya a 5.
      • Si no lo es, el procesamiento de datos es lento. Póngase en contacto con .
    • Si no, vaya a 7.

  5. Haga clic en Abnormal o Failed en la fila donde se encuentra el trabajo y rectifique el error basándose en la información de error mostrada en la página.
  6. Después de rectificar la falla, vuelva a ejecutar el trabajo y compruebe si el trabajo se puede ejecutar correctamente.

    • En caso afirmativo, no es necesario hacer nada más.
    • Si no, vaya a 7.

Recopilar información de fallas.

  1. En FusionInsight Manager, seleccione O&M. En el panel de navegación de la izquierda, elija Log > Download.
  2. Seleccione CDL en el clúster necesario para Service.
  3. Haga clic en en la esquina superior derecha y establezca Start Date y End Date para la recopilación de registros en 30 minutos antes y después del tiempo de generación de alarmas respectivamente. A continuación, haga clic en Download.
  4. Póngase en contacto con y proporcione los registros recopilados.

Eliminación de alarmas

Esta alarma se borra cuando la cantidad de datos en cola en la ranura de replicación es menor que el umbral. No es necesario borrar manualmente la alarma.

Información relacionada

Ninguna

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