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Centro de ayuda/ MapReduce Service/ Guía del usuario/ Referencia de alarma (aplicable a MRS 3.x)/ ALM-45616 Excepción de ejecución de trabajo de CDL

ALM-45616 Excepción de ejecución de trabajo de CDL

Actualización más reciente 2023-11-20 GMT+08:00

Descripción

El sistema comprueba si un trabajo de CDL es normal cada 60 segundos. Esta alarma se notifica cuando el trabajo de CDL es anormal. Esta alarma se borra cuando se restablece o se detiene el trabajo.

Atributo

ID de alarma

Severidad de alarma

Borrar automáticamente

45616

Grave

Parámetros

Nombre

Significado

Source

Especifica el clúster para el que se genera la alarma.

ServiceName

Especifica el servicio para el que se genera la alarma.

JobName

Especifica el trabajo para el que se genera la alarma.

Username

Especifica el nombre de usuario del trabajo para el que se genera la alarma.

Impacto en el sistema

Esta alarma no tiene impacto en el sistema.

Causas posibles

La tarea CDL no se puede ejecutar debido a una configuración de parámetros incorrecta u otras razones. En la página Job Management de la interfaz de usuario web de CDL, busque la fila donde se encuentra el trabajo y haga clic en Failed/Abnormal running en la columna Status para ver la causa de error o ver la causa de error en los registros.

Procedimiento

  1. Inicie sesión en FusionInsight Manager como un usuario que tiene el permiso de creación de trabajos de CDL o administrador.
  2. Elija O&M. En el panel de navegación de la izquierda, elija Alarm > Alarms, haga clic en en la fila donde Alarm ID es 45616, y vea el nombre del trabajo para el que se genera esta alarma en Location.
  3. Elija Cluster > Services > CDL y haga clic en el enlace situado junto a la CDLService UI para ir a la interfaz de usuario web de CDL.
  4. Busque la fila en la que se encuentra el trabajo fallido en función del nombre del trabajo obtenido en 2 y haga clic en Abnormal running o Failed en al columna Status.

  5. En la página que se muestra, vea la información de error y rectifique el error. Por ejemplo, Figura 1 muestra que la tarea que se ejecuta en Yarn se elimina manualmente. Para obtener más información, consulte la información de error de seguimiento, como se muestra en Figura 2.

    Figura 1 Excepción de trabajo de CDL
    Figura 2 Rastrear información de error

  6. Rectifique el error basado en la información de error, ejecute la tarea de nuevo y compruebe si la tarea se puede ejecutar correctamente.

    • En caso afirmativo, no es necesario hacer nada más.
    • Si no, vaya a 7.

Recopilar información de fallas.

  1. En FusionInsight Manager, seleccione O&M. En el panel de navegación de la izquierda, elija Log > Download.
  2. Seleccione CDL en el clúster necesario para Service.
  3. Haga clic en en la esquina superior derecha y establezca Start Date y End Date para la recopilación de registros en 30 minutos antes y después del tiempo de generación de alarmas respectivamente. A continuación, haga clic en Download.
  4. Póngase en contacto con y proporcione los registros recopilados.

Eliminación de alarmas

Después de que el trabajo se restablezca o se detenga con éxito, la alarma se borra si se ha notificado.

Información relacionada

Ninguna

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