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Actualización más reciente 2023-11-20 GMT+08:00

ALM-38006 El porcentaje de Partition de Kafka que no están completamente sincronizadas supera el umbral

Descripción

El sistema comprueba el porcentaje de Partition de Kafka que no están completamente sincronizadas con el número total de Partition cada 60 segundos. Esta alarma se genera cuando el porcentaje excede el umbral (50% por defecto) durante 3 veces consecutivas.

Cuando el Trigger Count es 1, esta alarma se borra cuando el porcentaje es menor o igual al umbral. Cuando el Trigger Count es mayor que 1, esta alarma se borra cuando el porcentaje es menor o igual al 90% del umbral.

Atributo

ID de alarma

Gravedad de la alarma

Borrado automáticamente

38006

Importante

Parámetros

Nombre

Significado

Source

Especifica el clúster para el que se genera la alarma.

ServiceName

Especifica el servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

Trigger Condition

Especifica el umbral que activa la alarma. Si el valor del indicador actual excede este umbral, se genera la alarma.

Impacto en el sistema

Demasiadas Partitions de Kafka que no están completamente sincronizadas afectan a la confiabilidad del servicio. Además, los datos pueden perderse cuando se conmutan Leader.

Causas posibles

Algunos nodos en los que reside la instancia del Broker son anormales o dejan de ejecutarse. Como resultado, las réplicas de algunas Partitions en Kafka están fuera del conjunto de réplicas in-sync (ISR).

Procedimiento

Comprobar instancias de Broker.

  1. En el portal del FusionInsight Manager, seleccione Cluster > Name of the desired cluster > Services > Kafka > Instance. Se muestra la página de instancias de Kafka.
  2. Compruebe si existen nodos defectuosos entre todos los nodos del Broker.

    • En caso afirmativo, registre el nombre de host del nodo y vaya a 3.
    • Si no, vaya a 5.

  3. En el portal del FusionInsight Manager, haga clic en O&M > Alarm > Alarms para comprobar si la falla descrita en 2 existe en la información de alarma y manejar la alarma basándose en los métodos correspondientes.
  4. En el portal del FusionInsight Manager, seleccione Cluster > Name of the desired cluster > Services > Kafka > Instance. Se muestra la página de instancias de Kafka.
  5. Compruebe si existen nodos detenidos entre todas las instancias del Broker.

    • En caso afirmativo, vaya a 6.
    • Si no, vaya a 7.

  6. Seleccione todas las instancias de Broker detenidas y haga clic en Start Instance.
  7. Verifique si la alarma se ha borrado.

    • De ser así, no se requiere ninguna acción adicional.
    • Si no, vaya a 8.

Recopilar información de fallas.

  1. En el portal de FusionInsight Manager, seleccione O&M > Log > Download.
  2. Seleccione Kafka en el clúster requerido en la lista desplegable Service.
  3. Haga clic en en la esquina superior derecha y establezca Start Date y End Date para la recopilación de registros en 10 minutos antes y después del tiempo de generación de alarmas, respectivamente. A continuación, haga clic en Download.
  4. Póngase en contacto con el y envíe los registros recopilados.

Eliminación de alarmas

Después de rectificar la falla, el sistema borra automáticamente esta alarma.

Información relacionada

Ninguna