Estos contenidos se han traducido de forma automática para su comodidad, pero Huawei Cloud no garantiza la exactitud de estos. Para consultar los contenidos originales, acceda a la versión en inglés.
Centro de ayuda/ MapReduce Service/ Guía del usuario/ Referencia de alarma (aplicable a MRS 3.x)/ ALM-38007 El estado del usuario predeterminado de Kafka es anormal
Actualización más reciente 2023-11-20 GMT+08:00

ALM-38007 El estado del usuario predeterminado de Kafka es anormal

Descripción

El sistema comprueba el usuario predeterminado de Kafka cada 60 segundos. Esta alarma se genera cuando el sistema detecta que el estado del usuario es anormal.

Trigger Count está establecido en 1. Esta alarma se borra cuando el estado de usuario se vuelve normal.

Atributo

ID de alarma

Gravedad de la alarma

Borrado automáticamente

38007

Crítica

Parámetros

Nombre

Significado

Source

Especifica el clúster para el que se genera la alarma.

ServiceName

Especifica el servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

HostName

Especifica el nombre de host para el que se genera la alarma.

Trigger Condition

Especifica la condición de que el estado de usuario predeterminado de Kafka es anormal.

Impacto en el sistema

Si el estado de usuario predeterminado de Kafka es anormal, la sincronización de metadatos entre Brokers y la interacción entre Kafka y ZooKeeper se verá afectada, lo que afectará a la producción de servicios, el consumo y la creación y eliminación de temas.

Causas posibles

  • El servicio Sssd es anormal.
  • Algunas instancias de Broker dejan de ejecutarse.

Procedimiento

Compruebe si el servicio Sssd es anormal.

  1. En el portal del FusionInsight Manager, elija O&M > Alarm > Alarms > Status of Kafka Default User Is Abnormal > Location para comprobar el nombre de host de la instancia para la que se genera la alarma.
  2. Encuentre la información del host en la información de alarma e inicie sesión en el host.
  3. Ejecute el comando id -Gn kafka y compruebe si se muestra "No such user" en la salida del comando.

    • En caso afirmativo, registre el nombre de host del nodo y vaya a 4.
    • Si no, vaya a 6.

  4. En la página de inicio del FusionInsight Manager, seleccione O&M > Alarm > Alarms. Compruebe si hay Sssd Service Exception en la información de alarma. Si lo hay, maneje la alarma basándose en la información de alarma.

Verifique el estado de ejecución de la instancia de Broker.

  1. En la página principal del FusionInsight Manager, elija Cluster > Name of the desired cluster > Services > Kafka > Instance. Se muestra la página de instancia de Kafka.
  2. Compruebe si hay nodos detenidos en todas las instancias del Broker.

    • En caso afirmativo, vaya a 7.
    • Si no, vaya a 8.

  3. Seleccione todas las instancias de Broker detenidas y haga clic en Start Instance.
  4. Verifique si la alarma se ha borrado.

    • De ser así, no se requiere ninguna acción adicional.
    • Si no, vaya a 9.

Recopilar información de fallas.

  1. En FusionInsight Manager, elija O&M > Log > Download.
  2. En el área Service , seleccione Kafka en el clúster requerido.
  3. Haga clic en en la esquina superior derecha y establezca Start Date y End Date para la recopilación de registros en 10 minutos antes y después del tiempo de generación de alarmas, respectivamente. A continuación, haga clic en Download.
  4. Póngase en contacto con el y envíe los registros recopilados.

Eliminación de alarmas

Después de rectificar la falla, el sistema borra automáticamente esta alarma.

Información relacionada

Ninguna