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Actualización más reciente 2023-11-20 GMT+08:00

ALM-26053 El uso de Storm Slot supera el umbral

Descripción

El sistema comprueba el uso de la ranura cada 60 segundos y compara el uso real de la ranura con el umbral. Esta alarma se genera cuando el uso de ranura es mayor que el umbral.

Puede cambiar el umbral en O&M > Alarm > Thresholds.

Esta alarma se borra cuando el uso de ranura es menor o igual que el umbral.

Atributo

ID de alarma

Gravedad de la alarma

Borrado automáticamente

26053

Importante

Parámetros

Nombre

Significado

Source

Especifica el clúster para el que se genera la alarma.

ServiceName

Especifica el servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

HostName

Especifica el host para el que se genera la alarma.

Trigger condition

Especifica el umbral que activa la alarma. Si el valor del indicador actual excede este umbral, se genera la alarma.

Impacto en el sistema

No se pueden realizar nuevas tareas de Storm.

Causas posibles

  • El estado de algunos Supervisores en el clúster es anormal.
  • El estado de todos los Supervisores es normal, pero la capacidad de procesamiento es insuficiente.

Procedimiento

Comprobar el estado del supervisor.

  1. Seleccione Cluster > Name of the desired cluster > Services > Storm > Instance para ir a la página de gestión de instancias de Storm.
  2. Compruebe si existe alguna instancia cuyo estado sea Faulty o Restoring.

    • En caso afirmativo, vaya a 3.
    • Si no, vaya a 5.

  3. Seleccione las instancias de rol de supervisor cuyo estado es Faulty o Restoring, elija More > Restart Instance, y compruebe si las instancias se reinician correctamente.

    • En caso afirmativo, vaya a 4.
    • Si no, vaya a 10.

  4. Espere varios minutos y compruebe si la alarma está desactivada.

    • De ser así, no se requiere ninguna acción adicional.
    • Si no, vaya a 5.

Aumentar el número de espacios en cada Supervisor.

  1. Inicie sesión en el portal del FusionInsight Manager, elija Cluster > Name of the desired cluster > Services > Storm > Configurations > All Configurations.
  2. Aumente el número de puertos en el parámetro supervisor.slots.ports de cada rol Supervisor y reinicie la instancia.
  3. Espere varios minutos y compruebe si la alarma está desactivada.

    • De ser así, no se requiere ninguna acción adicional.
    • Si no, vaya a 8.

  1. Realice la ampliación de la capacidad para Supervisor.
  2. Espere varios minutos y compruebe si la alarma está desactivada.

    • De ser así, no se requiere ninguna acción adicional.
    • Si no, vaya a 10.

      Los servicios se interrumpen cuando se está reiniciando el Supervisor. A continuación, los servicios se restauran después del reinicio.

Recopilar información de fallas.

  1. En el portal del FusionInsight Manager, seleccione O&M > Log > Download.
  2. Seleccione Storm y ZooKeeper en el clúster requerido en el cuadro de lista desplegable Service.
  3. Haga clic en en la esquina superior derecha y establezca Start Date y End Date para la recopilación de registros en 1 hora antes y después del tiempo de generación de alarma, respectivamente. A continuación, haga clic en Download.
  4. Póngase en contacto con el y envíe los registros recopilados.

Eliminación de alarmas

Después de rectificar la falla, el sistema borra automáticamente esta alarma.

Información relacionada

Ninguna