ALM-26052 El número de Supervisor disponible del servicio de Storm es menor que el umbral
Descripción
El sistema comprueba periódicamente el número de Supervisor disponibles cada 60 segundos y compara el número de Supervisor disponible con el umbral. Esta alarma se genera cuando el número de Supervisor disponible es menor que el umbral.
Puede cambiar el umbral en O&M > Alarm > Thresholds > Name of the desired cluster.
Esta alarma se borra cuando el número de Supervisor disponible es mayor o igual que el umbral.
Atributo
ID de alarma |
Gravedad de la alarma |
Borrado automáticamente |
---|---|---|
26052 |
Importante |
Sí |
Parámetros
Nombre |
Significado |
---|---|
Source |
Especifica el clúster para el que se genera la alarma. |
ServiceName |
Especifica el servicio para el que se genera la alarma. |
RoleName |
Especifica el rol para el que se genera la alarma. |
HostName |
Especifica el host para el que se genera la alarma. |
Trigger condition |
Especifica el umbral que activa la alarma. Si el valor del indicador actual excede este umbral, se genera la alarma. |
Impacto en el sistema
No se pueden realizar tareas existentes en el clúster. El clúster puede recibir nuevas tareas de Storm, pero no puede realizar estas tareas.
Causas posibles
El estado de algunos Supervisores en el clúster es anormal.
Procedimiento
Comprobar el estado del supervisor.
- Seleccione Cluster > Name of the desired cluster > Services > Storm > Supervisor para ir a la página de gestión de servicio de Storm.
- En Roles, compruebe si existe cualquier instancia cuyo estado sea Faulty o Restoring.
- Seleccione las instancias de rol de supervisor cuyo estado es Faulty o Restoring, elija More > Restart Instance, y compruebe si las instancias se reinician correctamente.
- Espere 30 segundos y compruebe si la alarma está desactivada.
- De ser así, no se requiere ninguna acción adicional.
- Si no, vaya a 5.
Los servicios se interrumpen cuando se está reiniciando el Supervisor. A continuación, los servicios se restauran después del reinicio.
Recopilar información de fallas.
- En el portal del FusionInsight Manager, seleccione O&M > Log > Download.
- Seleccione Storm y ZooKeeper en el clúster requerido en el cuadro de lista desplegable Service.
- Haga clic en en la esquina superior derecha y establezca Start Date y End Date para la recopilación de registros en 1 hora antes y después del tiempo de generación de alarma, respectivamente. A continuación, haga clic en Download.
- Póngase en contacto con el y envíe los registros recopilados.
Eliminación de alarmas
Después de rectificar la falla, el sistema borra automáticamente esta alarma.
Información relacionada
Ninguna