ALM-13010 El uso de Znode de un directorio con cuota configurada supera el umbral
Descripción
El sistema comprueba el uso de Znode de todos los directorios de servicio con cuota configurada cada hora. Esta alarma se genera cuando el sistema detecta que el uso de Znode de nivel 2 excede el umbral.
Atributo
ID de alarma |
Gravedad de la alarma |
Borrado automáticamente |
---|---|---|
13010 |
Importante |
Sí |
Parámetros
Nombre |
Significado |
---|---|
Source |
Especifica el clúster para el que se genera la alarma. |
ServiceName |
Especifica el nombre del servicio para el que se genera la alarma. |
ServiceDirectory |
Especifica el directorio para el que se genera la alarma. |
RoleName |
Especifica el rol para el que se genera la alarma. |
Trigger Condition |
Especifica la causa de la alarma. |
Impacto en el sistema
Se escribe una gran cantidad de datos en el directorio de datos de ZooKeeper. Como resultado, ZooKeeper no puede proporcionar los servicios correctamente.
Causas posibles
- Se escribe una gran cantidad de datos en el directorio de datos de ZooKeeper.
- El umbral definido por el usuario es inapropiado.
Procedimiento
Comprobar si se escribe una gran cantidad de datos en el directorio para el que se genera la alarma.
- En FusionInsight Manager, elija O&M >Alarm > Alarms. Confirme el Znode para el que se genera la alarma en Location de esta alarma.
- Elija Cluster > Name of the desired cluster > Services > ZooKeeper y haga clic en Resource. En el caso de Used Resources (By Second-Level Znode), compruebe si se escribe una gran cantidad de datos en el Znode superior.
- Inicie sesión en el administrador de FusionInsight, elija O&M > Alarm > Alarms, seleccione Location en el cuadro de lista desplegable junto a ALM-13010 Znode Usage of a Directory with Quota Configured Exceeds the Threshold, y obtenga la ruta de Znode de ServiceDirectory.
- Inicie sesión en el cliente de ZooKeeper como usuario del clúster y elimine los datos no deseados en el Znode para el que se genera la alarma.
- Inicie sesión en el Administrador de FusionInsight y elija Cluster > Name of the desired cluster > Services > Component of the top Znode for which the alarm isgenerated. Elija Configurations > All Configurations, busque zk.quota.number, aumente su valor, haga clic en Save.
Si el componente del Znode superior para el que se genera la alarma es de ClickHouse, cambie el valor de ClickHouse.zookeeper.quota.node.count.
- Verifique si la alarma se ha borrado.
- De ser así, no se requiere ninguna acción adicional.
- Si no, vaya a 7.
Recopilar información de fallas.
- En el portal del FusionInsight Manager, elija O&M > Log > Download.
- Seleccione ZooKeeper en el clúster requerido en el Service.
- Haga clic en en la esquina superior derecha y establezca Start Date y End Date para la recopilación de registros en 10 minutos antes y después del tiempo de generación de alarmas, respectivamente. A continuación, haga clic en Download.
- Póngase en contacto con el y envíe los registros recopilados.
Eliminación de alarmas
Después de rectificar la falla, el sistema borra automáticamente esta alarma.
Información relacionada
Ninguna