ALM-14000 Servicio HDFS no disponible
Descripción
El sistema comprueba el estado del servicio NameService cada 60 segundos. Esta alarma se genera cuando todos los servicios de NameService son anormales y el sistema considera que el servicio HDFS no está disponible.
Esta alarma se borra cuando al menos un servicio NameService es normal y el sistema considera que el servicio HDFS se recupera.
Atributo
ID de alarma |
Gravedad de la alarma |
Borrado automáticamente |
---|---|---|
14000 |
Crítica |
Sí |
Parámetros
Nombre |
Significado |
---|---|
Source |
Especifica el clúster para el que se genera la alarma. |
ServiceName |
Especifica el servicio para el que se genera la alarma. |
RoleName |
Especifica el rol para el que se genera la alarma. |
HostName |
Especifica el host para el que se genera la alarma. |
Impacto en el sistema
HDFS no proporciona servicios para componentes de capa superior basados en servicios HDFS, como HBase y MapReduce. Como resultado, los usuarios no pueden leer ni escribir archivos.
Causas posibles
- El servicio ZooKeeper es anormal.
- Todos los servicios de NameService son anormales.
Procedimiento
Verificar el estado del servicio de ZooKeeper.
- En el portal del FusionInsight Manager, seleccione O&M > Alarm > Alarms. En la página Alarma, compruebe si se ha informado de ALM-13000 Servicio ZooKeeper no disponible.
- Consulte ALM-13000 Servicio ZooKeeper no disponible para corregir el estado de salud de la falla de ZooKeeper y comprueba si el Running Status del servicio ZooKeeper se restaura a Normal.
- En la página O&M > Alarm > Alarms, compruebe si la alarma está desactivada.
- De ser así, no se requiere ninguna acción adicional.
- Si no, vaya a 4.
Manejar la alarma de excepción del servicio NameService.
- En el portal del FusionInsight Manager, seleccione O&M > Alarm > Alarms. En la página Alarmas, compruebe si se ha informado de ALM-14010 Servicio NameService no disponible.
- Vea ALM-14010 Servicio NameService no disponible para controlar los servicios anormales de NameService y compruebe si cada alarma de excepción de servicio de NameService está desactivada.
- En la página O&M > Alarm > Alarms, compruebe si la alarma está desactivada.
- De ser así, no se requiere ninguna acción adicional.
- Si no, vaya a 7.
Recopilar información de fallas.
- En el portal del FusionInsight Manager, elija O&M > Log > Download.
- Seleccione los siguientes nodos en el clúster requerido desde el Service:
- ZooKeeper
- HDFS
- Haga clic en en la esquina superior derecha y establezca Start Date y End Date para la recopilación de registros en 10 minutos antes y después del tiempo de generación de alarmas, respectivamente. A continuación, haga clic en Download.
- Póngase en contacto con el y envíe los registros recopilados.
Eliminación de alarmas
Después de rectificar la falla, el sistema borra automáticamente esta alarma.
Información relacionada
Ninguna