ALM-12103 Excepción de recursos del executor
Descripción
HA comprueba los recursos del Executor de Manager cada 30 segundos. Esta alarma se genera cuando HA detecta que los recursos del Executor son anormales durante dos veces consecutivas.
Esta alarma se borra cuando los recursos del Executor son normales.
Resource Type de Executor es Single-active. Activo/en espera se activará en caso de excepciones de recursos. Cuando se genera esta alarma, se completa la conmutación activa/en espera y se han habilitado nuevos recursos de Executor en el nuevo Manager activo. En este caso, esta alarma se borra. Esta alarma se utiliza para notificar a los usuarios de la causa de la conmutación del Manager activo/en espera.
Atributo
ID de alarma |
Severidad de alarma |
Borrar automáticamente |
---|---|---|
12103 |
Grave |
Sí |
Parámetros
Nombre |
Significado |
---|---|
Source |
Especifica el clúster o sistema para el que se genera la alarma. |
ServiceName |
Especifica el servicio para el que se genera la alarma. |
RoleName |
Especifica el rol para el que se genera la alarma. |
HostName |
Especifica el host para el que se genera la alarma. |
Impacto en el sistema
- Se produce el cambio de Manager activo/en espera.
- El proceso Executor sigue reiniciando. Como resultado, es posible que no se acceda a la página del clúster.
Causas posibles
El proceso del Executor es anormal.
Procedimiento
Comprobar si el proceso de Executor es anormal.
- En la lista de alarmas del FusionInsight Manager, busque la fila que contiene la alarma y haga clic en para ver el nombre del host para el que se genera la alarma.
- Inicie sesión en el host para el que se genera la alarma como usuario root.
- Ejecute el comando su - omm para cambiar a usuario omm.
- Ejecute el comando sh ${BIGDATA_HOME}/om-server/OMS/workspace0/ha/module/hacom/script/status_ha.sh para comprobar si el estado de los recursos del Executor gestionados por el HA es normal. En el sistema de nodo único, el recurso Executor está en el estado normal. En el sistema de nodo doble, el recurso Executor está en el estado normal en el nodo activo y en el estado detenido en el nodo de espera.
- Ejecute el comando vi $BIGDATA_LOG_HOME/omm/oms/ha/scriptlog/executor.log para comprobar si el registro de recursos del Executor de HA contiene la palabra clave ERROR. En caso afirmativo, analice el registro para localizar la causa de la excepción del recurso y corrija la excepción.
- Después de 5 minutos, compruebe si esta alarma está desactivada.
- En caso afirmativo, no es necesario hacer nada más.
- Si no, vaya a 7.
Recopilar información de fallas.
- En FusionInsight Manager, seleccione O&M. En el panel de navegación de la izquierda, elija Log > Download.
- En el área Services, seleccione Controller y OmmServer y haga clic en OK.
- Haga clic en en la esquina superior derecha y establezca Start Date y End Date para la recopilación de registros en 1 hora antes y después del tiempo de generación de alarma, respectivamente. A continuación, haga clic en Download.
- Póngase en contacto con y proporcione los registros recopilados.