ALM-12004 Recurso OLdap anormal
Descripción
El sistema comprueba los recursos LDAP cada 60 segundos. Esta alarma se genera cuando el sistema detecta que los recursos LDAP en Manager son anormales durante seis veces consecutivas.
Esta alarma se borra cuando el recurso Ldap en el Manager se recupera y se completa el manejo de alarmas.
Atributo
ID de alarma |
Gravedad de la alarma |
Borrar automáticamente |
---|---|---|
12004 |
Importante |
Sí |
Parámetros
Nombre |
Significado |
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Source |
Especifica el clúster o sistema para el que se genera la alarma. |
ServiceName |
Especifica el servicio para el que se genera la alarma. |
RoleName |
Especifica el rol para el que se genera la alarma. |
HostName |
Especifica el host para el que se genera la alarma. |
Impacto en el sistema
Los servicios de autenticación Manager y WebUI del componente no están disponibles y no pueden proporcionar funciones de autenticación de seguridad y gestión de usuarios para los servicios web de capa superior. Es posible que los usuarios no puedan iniciar sesión en los WebUIs de Manager y componentes.
Causas posibles
El proceso LdapServer en el Manager es anormal.
Procedimiento
Comprobar si el proceso de LdapServer en el Manager es normal.
- Inicie sesión en el nodo Manager en el clúster como usuario omm.
Inicie sesión en el FusionInsight Manager con la dirección IP flotante y ejecute el comando sh ${BIGDATA_HOME}/om-server/om/sbin/status-oms.sh para comprobar la información sobre el clúster actual de dos nodos del Manager.
- Ejecute el comando ps -ef | grep slapd para comprobar si el proceso de recursos LdapServer en ${BIGDATA_HOME}/om-server/om/ en el archivo de configuración del proceso se está ejecutando correctamente.
Puede determinar que el recurso es normal comprobando la siguiente información:
- Ejecute el comando kill -2 ldap pid para reiniciar el proceso LdapServer y espere 20 segundos. El HA inicia el proceso OLdap automáticamente. Compruebe si el recurso OLdap actual está en estado normal.
- En caso afirmativo, la operación se ha completado.
- Si no, vaya a 4.
Recopilar información de fallas.
- En la página de inicio del FusionInsight Manager, elija O&M > Log > Download.
- Seleccione OmsLdapServer y OmmServer del Service y haga clic en OK.
- Haga clic en en la esquina superior derecha y establezca Start Date y End Date para la recopilación de registros en 1 hora antes y después del tiempo de generación de alarma, respectivamente. A continuación, haga clic en Download.
- Póngase en contacto con el y envíe la información de registro recopilada.
Eliminación de alarmas
Después de rectificar la falla, el sistema borra automáticamente esta alarma.
Información relacionada
Ninguna