What Can I Do If the Selected Resource Pool Does Not Support Specifying Users?
Symptom
The Specify User option under More Settings cannot be enabled and the message The selected resource pool does not support specified users is displayed when a user creates a notebook instance.
Possible Causes
- Public resource pools do not support starting notebook instances as user root.
- Huawei Cloud ModelArts has hardened and optimized the dedicated resource pool network. Only dedicated resource pools in the new network mode support starting notebook instances as the root user. Dedicated resource pools in the old network mode do not support this function and will be gradually restricted from October 15, 2025. For details about how to check whether the old network mode is used and the announcement details, see ModelArts Standard Dedicated Resource Pool Network Adjustment.
Solution
You can resolve this issue by creating a dedicated resource pool based on a new network.
- Create a network and use it to create a dedicated resource pool. For details, see Creating a Dedicated Resource Pool.
- Use the new dedicated resource pool to create a notebook instance. For details, see Creating a Notebook Instance.
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