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Centro de ayuda/ GaussDB(DWS)/ Guía de gestión/ Monitoreo y alarmas/ Alarmas/ Manejo de alarmas/ DWS_2000000012 La latencia del disco de datos de nodo supera el umbral
Actualización más reciente 2024-06-12 GMT+08:00

DWS_2000000012 La latencia del disco de datos de nodo supera el umbral

Descripción

GaussDB(DWS) recopila la latencia del disco de datos de cada nodo en el clúster cada 30 segundos. Esta alarma se genera cuando la latencia media de un disco de datos en un nodo supera los 400 ms (configurable) en los últimos 10 minutos (configurable), y se borra automáticamente cuando la latencia media cae por debajo de 400 ms.

Si la latencia del disco de datos de un nodo es siempre mayor que el umbral de alarma, esta alarma se genera de nuevo después de 24 horas (configurable).

Atributos de alarma

ID de alarma

Gravedad de alarma

Borrar automáticamente

DWS_2000000012

Importante

Parámetros de alarmas

Parámetro

Descripción

Alarm Source

Indica el nombre del sistema para el que se genera la alarma, por ejemplo, GaussDB(DWS).

Cluster Name

Indica el clúster para el que se genera la alarma.

Location Information

Incluye ID y nombre del clúster para el que se genera la alarma, y ID y nombre de la instancia para la que se genera la alarma, por ejemplo, cluster_id: xxxx-xxxx-xxxx-xxxx, cluster_name: test_dws, instance_id: xxxx-xxxx-xxxx-xxxx, instance_name: test_dws-dws-cn-cn-1-1.

Detail Information

Información detallada sobre la alarma, incluida la información del clúster, la instancia, el disco y el umbral. Ejemplo: CloudService=DWS, resourceId= xxxx-xxxx-xxxx-xxxx, resourceIdName=test_dws, instance_id: xxxx-xxxx-xxxx-xxxx, instance_name: test_dws-dws-cn-cn-1-1, host_name: host-192-168-1-122, disk_name: /dev/vdb, first_alarm_time: 2022-01-30 10:30:00. El uso de E/S del disco de datos del nodo en 10 minutos es de 90.54 %, superando el umbral de 90 %.

Generated

Hora de generación de la alarma.

Status

Indica el estado de la alarma actual.

Impacto en el sistema

La alta latencia del disco ralentizará la velocidad de lectura/escritura de datos, lo que hará que el rendimiento del clúster se deteriore.

Causas posibles

La base de datos está en horas punta y hay un gran número de solicitudes de lectura y escritura.

Procedimiento de manejo

  1. En la página Clusters, busque la fila que contiene el clúster de destino y haga clic en Monitoring en la columna Operation.

  2. En el panel de navegación de la izquierda, elija Monitoring > Node Monitoring. En la página Node Monitoring, vea el uso de la CPU, el uso del disco y el uso de la memoria.

    Si el uso de la CPU y la velocidad de E/S del disco son altas, el clúster se encuentra en horas pico. Puede ajustar el umbral de latencia en función de los requisitos de servicio. Para más detalles, véase 3.

  3. Haga clic en Alarms, cambie a la página de fichas Alarms y haga clic en Alarm Rule Management en la esquina superior izquierda.
  4. Busque la fila que contiene Node Data Disk Latency Exceeds the Threashold y haga clic en Modify en la columna Operation. En la página mostrada, cambie el umbral.

Borrar alarmas.

Esta alarma se borra automáticamente cuando la latencia del disco de datos cae a un cierto valor.