Updated on 2025-06-07 GMT+08:00

UGO.10001009 Failed to connect to the database

Description

Source or target databases failed to be connected.

Possible Causes

The possible causes are as follows:

  1. The database connection information is incorrect.
  2. The user does not have privileges required to connect to the database.
  3. The database and UGO are disconnected.
  4. The database firewall restricts UGO access to the database.
  5. There are too many connections to the database.

Handling Suggestion

  1. Rectify the fault by following Database Connection.
  2. If the error cannot be fixed, trigger this error again on UGO.
  3. Take a screenshot of the error.
  4. In the upper right corner of the console, choose Service Tickets > Create Service Ticket and contact the customer service.