Help Center/ MapReduce Service/ User Guide (Ankara Region)/ Alarm Reference/ ALM-47000 MemArtsCC Instance Unavailable
Updated on 2024-11-29 GMT+08:00

ALM-47000 MemArtsCC Instance Unavailable

Alarm Description

The alarm module checks the MemArtsCC instance status every 60 seconds. This alarm is generated when the alarm module detects that the MemArtsCC instance on the current node is abnormal.

This alarm is cleared when the system detects that any MemArtsCC instance is restored.

Alarm Attributes

Alarm ID

Alarm Severity

Alarm Type

Service Type

Auto Cleared

47000

Major

Error handling

MemArtsCC

Yes

Alarm Parameters

Type

Parameter

Description

Location Information

Source

Specifies the cluster or system for which the alarm is generated.

ServiceName

Specifies the service for which the alarm is generated.

RoleName

Specifies the role for which the alarm is generated.

HostName

Specifies the host for which the alarm is generated.

Impact on the System

The MemArtsCC service is abnormal. You cannot use FusionInsight Manager to perform cluster operations on the MemArtsCC service. The MemArtsCC service function is unavailable.

Possible Causes

  • The cluster fails to be started due to incorrect configuration.
  • The ZooKeeper service is abnormal.

Handling Procedure

Check the MemArtsCC configuration.

  1. Log in to any MemArtsCC installation node as user root, go to the CCWorker log directory /var/log/Bigdata/memartscc/ccworker, and view the CCWorker startup log.
  2. Correct the configuration items in the logs and restart the service.
  3. Wait 5 minutes and check whether the alarm is cleared.

    • If yes, no further action is required.
    • If no, go to 4.

Check the ZooKeeper instance status.

  1. On FusionInsight Manager, choose Cluster > Services > ZooKeeper > Instance.
  2. Check whether ZooKeeper instances are normal.

    • If yes, go to 9.
    • If no, go to 6.

  3. Select ZooKeeper instances whose status is not good and choose More > Restart Instance.
  4. Check whether the instance status is good after restart.

    • If yes, go to 8.
    • If no, go to 9.

  5. Choose O&M > Alarm > Alarms and check whether the alarm is cleared.

    • If yes, no further action is required.
    • If no, go to 9.

Collect fault information.

  1. On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
  2. Expand the Service drop-down list, and select MemArtsCC for the target cluster.
  3. Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
  4. Contact O&M personnel and send the collected logs.

Alarm Clearance

This alarm is automatically cleared after the fault is rectified.

Related Information

None