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Help Center/ MapReduce Service/ User Guide (Ankara Region)/ Alarm Reference/ ALM-46012 Abnormal Nginx of MOTService

ALM-46012 Abnormal Nginx of MOTService

Updated on 2024-11-29 GMT+08:00

Alarm Description

The system checks the Nginx status of MOTService every 10 seconds. This alarm is generated when the Nginx service has been detected to be abnormal for 10 consecutive times during the HA health check.

This alarm is cleared when the Nginx service becomes normal during the HA health check.

Alarm Attributes

Alarm ID

Alarm Severity

Alarm Type

Service Type

Auto Cleared

46012

Major

Quality of service

MOTService

Yes

Alarm Parameters

Type

Parameter

Description

Location Information

Source

Specifies the cluster for which the alarm was generated.

ServiceName

Specifies the service for which the alarm was generated.

RoleName

Specifies the role for which the alarm was generated.

HostName

Specifies the host for which the alarm was generated.

Impact on the System

If Nginx is abnormal, services may fail to access MOTService using the floating IP address. As a result, MOTService is unavailable and cannot provide functions such as data import and query for upper-layer services.

Possible Causes

The Ngnix service is not running properly.

Handling Procedure

Check whether the Ngnix service on the node where MOTService resides is normal.

  1. Log in to FusionInsight Manager.
  2. Choose O&M > Alarm > Alarms. On the page that is displayed, locate the row containing this alarm, and obtain the name of the host for which the alarm is generated in Location.
  3. Choose Cluster > Services > MOTService. On the page that is displayed, click the Instance tab and obtain the service IP address of the host for which this alarm is generated.
  4. Log in to the node in 3 as user omm.
  5. Run the following command to check the Nginx status:

    lsof -i "TCP@$MOTService floating IP address:20105" | grep -q "nginx"

    If the following information is displayed, the status is normal:
    ngnix  Normal  Normal   Single_active
    NOTE:

    You can also log in to FusionInsight Manager, choose Cluster > Services > MOTService > Configurations > All Configurations, search for the motservice.floatip parameter, and obtain its value, which is the floating IP address of MOTService.

    • If yes, go to 8.
    • If no, go to 6.

  6. Contact the network administrator to check whether the network is faulty and whether the floating IP address is incorrect.

    • If yes, repair the network, configure a correct floating IP address, and go to 7.
    • If no, go to 8.

  7. Wait 5 minutes and check whether the alarm is cleared.

    • If yes, no further action is required.
    • If no, go to 8.

Collect fault information.

  1. On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
  2. Expand the Service drop-down list and select MOTService.
  3. Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 30 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
  4. Contact O&M personnel/Technical support and provide the collected logs.

Alarm Clearance

This alarm is automatically cleared after the fault is rectified.

Related Information

None

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