Help Center> Data Warehouse Service (DWS)> Management Guide> Monitoring and Alarms> Alarms> Alarm Handling> DWS_2000000017 Number of Queuing Query Statements Exceeds the Threshold
Updated on 2024-06-14 GMT+08:00

DWS_2000000017 Number of Queuing Query Statements Exceeds the Threshold

Description

When real-time query monitoring is enabled, GaussDB(DWS) checks the queuing status of jobs on CNs through the GS_WLM_SESSION_STATISTICS view every 60 seconds by default.

This alarm is generated when the number of queuing SQL statements in the cluster exceeds 10 (configurable) within 10 minutes (configurable), and is automatically cleared when the number of queuing SQL statements drops below 10.

If there continues to be queuing query statements more than the alarm threshold, the alarm is generated again 24 hours later (configurable).

Alarm Attributes

Alarm ID

Alarm Severity

Auto Clear

DWS_2000000017

Critical

Yes

Alarm Parameters

Parameter

Description

Alarm Source

Indicates the name of the system for which the alarm is generated and the detailed alarm type.

Cluster Name

ID of the cluster for which the alarm is generated

Location Information

ID and name of the cluster for which the alarm is generated

Detail Information

CloudService indicates the cloud service for which the alarm is generated, including the service name, resource ID, resource name, first alarm time, and formatted alarm information. Example: CloudServiceDWS, resourceId=xxxx-xxxx-xxxx-xxxx, resourceIdName=test_dws, first_alarm_time:2023-01-11:19:02:09. The average number of query statements queuing in cluster test_dws within 10 minutes is 30, which exceeds the threshold 10.

Generated

Time when an alarm is generated.

Status

Indicates the status of the current alarm.

Impact on the System

SQL queries are blocked. As a result, the execution time is too long.

Possible Causes

The number of queuing query statements during service execution exceeds the alarm threshold.

Handling Procedure

Check whether the current queuing jobs in the cluster are normal.

  1. Log in to the GaussDB(DWS) console.
  2. On the Alarms page, select the current cluster from the cluster selection drop-down list in the upper right corner and view the alarm information of the cluster in the last seven days. Locate the name of the cluster that triggers the alarm based on the location information.
  3. On the Clusters > Dedicated Clusters page, locate the row that contains the cluster for which the alarm is generated and click Monitoring Panel in the Operation column.
  4. Choose Monitoring > Queries to view the real-time sessions and queries of the current cluster. Select the Queries tab to view the status of jobs being executed in the current cluster. Click and select Blocking Time (ms) and Waiting status. Click to sort the values of Blocking Time (ms). You can view the information about the waiting SQL statements with the longest blocking time. If a query job is in the waiting state and the blocking time is abnormal, you can terminate the query.

    Current queuing status of the statements, including:

    • Global: global queuing.
    • Respool: resource pool queuing.
    • CentralQueue: queuing on the CCN
    • Transaction: being in a transaction block
    • StoredProc: being in a stored procedure
    • None: not in a queue
    • Forced None: being forcibly executed (transaction block statement or stored procedure statement are) because the statement waiting time exceeds the specified value

Alarm Clearance

This alarm is automatically cleared when the number of queuing statements drops below the threshold.