Help Center/ GaussDB/ FAQs/ Database Storage/ What Should I Do If My Data Exceeds the Available Storage of a GaussDB Instance?
Updated on 2024-05-07 GMT+08:00

What Should I Do If My Data Exceeds the Available Storage of a GaussDB Instance?

Symptom

There is not enough storage available for a GaussDB instance and the instance becomes read-only, so applications cannot write any data to the instance.

Possible Causes

  1. Increased workload data
  2. Too much data being stored
  3. Too many logs generated due to a large number of transactions and write operations
  4. Too many temporary files generated due to a large number of sorting queries executed by applications

Solution

  1. For insufficient storage caused by increased workload data, scale up storage space.

    If the original storage has reached the maximum, upgrade the instance specifications first.

  2. If too much data is stored, delete unnecessary historical data.
    1. If the instance becomes read-only, you need to contact customer service to cancel the read-only status first.
    2. To clear up space, you can optimize tables with a high fragmentation rate during off-peak hours.

      To delete data of an entire table, use the DROP or TRUNCATE statement. To delete part of table data, use the DELETE statement.

  3. If log files occupy too much storage, clear log files to release storage space.
  4. If temporary files generated by sorting queries occupy too much storage space, optimize your SQL statements.