Managing Incident Tickets
Function
This API is used to accept, handle (submit solutions), reject, escalate, de-escalate, and suspend incident tickets as well as verify the handling results.
The action value and param parameter vary according to the operation. This API is used to obtain task IDs together with the API in Obtaining an Incident Task.
Authorization
Each account has all of the permissions required to call all APIs, but IAM users must have the required permissions specifically assigned.
- If you are using role- or policy-based authorization, refer to Permissions Policies and Supported Actions to obtain the permissions required.
- If you are using identity policy-based authorization, the permission listed below is required.
Action
Access Level
Resource Type (*: required)
Condition Key
Alias
Dependent Action
coc:ticket:action
Write
-
-
-
-
URI
POST /v2/incidents/{incident_id}/actions
|
Parameter |
Type |
Mandatory |
Description |
|---|---|---|---|
|
incident_id |
String |
Yes |
Definition: Incident ticket No. Constraints String Range: Length: 1 to 50 characters Default Value: N/A |
Request Parameters
|
Parameter |
Type |
Mandatory |
Description |
|---|---|---|---|
|
task_id |
String |
Yes |
Definition: For details, see the task ID returned in Task APIs. Constraints Length: 1 to 100 characters Range: N/A Default Value: N/A |
|
action |
String |
Yes |
Definition: Operation type with different IDs. The operations that can be performed depend on the value of TaskOperateKey returned in Task APIs. Constraints Length: 1 to 100 characters Range:
Default Value: N/A |
|
params |
Map<String,Object> |
No |
Definition: Parameters (mapping) and mandatory items vary depending on the operation (action). Constraints Map type. For details, see the value range. Range:
Default Value: N/A |
|
Parameter |
Type |
Mandatory |
Description |
|---|---|---|---|
|
virtual_schedule_type |
String |
No |
Definition: Shift scenario. Constraints Length: 0 to 255 characters Shift scenario, shift role, and owner. The values cannot be empty at the same time. If all of values are specified, the owner is used first. Range: N/A Default Value: N/A |
|
virtual_schedule_role |
String |
No |
Definition: Shift role. Constraints Length: 0 to 255 characters Range: N/A Default Value: N/A |
|
virtual_send_assignee |
String |
No |
Definition: Forwarding owner. Constraints Length: 0 to 255 characters If the owner is empty, the shift scenario and role must be specified. Range: N/A Default Value: N/A |
|
virtual_send_comment |
String |
No |
Definition: Remarks. Constraints Length: 0 to 300 characters Range: N/A Default Value: N/A |
|
virtual_current_location_info |
String |
No |
Definition: Current phase location. Constraints Length: 0 to 300 characters Range: N/A Default Value: N/A |
|
Parameter |
Type |
Mandatory |
Description |
|---|---|---|---|
|
note |
String |
Yes |
Definition: Remarks. Constraints Length: 0 to 300 characters Range: N/A Default Value: N/A |
|
Parameter |
Type |
Mandatory |
Description |
|---|---|---|---|
|
mtm_type |
String |
Yes |
Definition: Issue type Constraints Length: 0 to 255 characters Range: N/A Default Value: N/A |
|
is_service_interrupt |
Boolean |
Yes |
Definition: Whether the service is interrupted. Constraints N/A Range: true/false Default Value: N/A |
|
start_time |
Long |
No |
Definition: Fault occurrence time, in timestamp format. Constraints This parameter is mandatory when is_service_interrupt is set to true. Range: 1-999999999 Default Value: N/A |
|
fault_recovery_time |
Long |
No |
Definition: Fault recovery time, in timestamp format. Constraints This parameter is mandatory when is_service_interrupt is set to true. Range: 1-999999999 Default Value: N/A |
|
cause |
String |
No |
Definition: Failure causes. Constraints Length: 0 to 10,000 characters Range: N/A Default Value: N/A |
|
solution |
String |
No |
Definition: Solution. Constraints Length: 0 to 10,000 characters Range: N/A Default Value: N/A |
|
resolve_attachments |
String |
No |
Definition: Attachment ID. Constraints Length: 0 to 255 characters Range: N/A Default Value: N/A |
|
Parameter |
Type |
Mandatory |
Description |
|---|---|---|---|
|
virtual_confirm_result |
Boolean |
Yes |
Definition: Whether the issue is resolved. Constraints N/A Range: true/false Default Value: N/A |
|
virtual_confirm_comment |
String |
Yes |
Definition: Remarks. This parameter is mandatory for incident ticket review. Constraints Length: 0 to 300 characters Range: N/A Default Value: N/A |
|
Parameter |
Type |
Mandatory |
Description |
|---|---|---|---|
|
pause_end_time |
Long |
Yes |
Definition: Pause end time. The value is a timestamp. Constraints N/A Range: 1-999999999 Default Value: N/A |
|
pause_reason |
String |
Yes |
Definition: Suspension reason. Constraints Length: 0 to 255 characters Range: N/A Default Value: N/A |
|
Parameter |
Type |
Mandatory |
Description |
|---|---|---|---|
|
pause_approve_conclusion |
Boolean |
Yes |
Definition: Whether the application is approved. The fixed value is true. Constraints N/A Range: true Default Value: N/A |
|
note |
String |
Yes |
Definition: Remarks. Constraints Length: 0 to 1,024 characters Range: N/A Default Value: N/A |
|
Parameter |
Type |
Mandatory |
Description |
|---|---|---|---|
|
pause_approve_conclusion |
Boolean |
Yes |
Definition: Whether the application is approved. The fixed value is false. Constraints N/A Range: false Default Value: N/A |
|
note |
String |
Yes |
Definition: Remarks. Constraints Length: 0 to 1,024 characters Range: N/A Default Value: N/A |
|
Parameter |
Type |
Mandatory |
Description |
|---|---|---|---|
|
virtual_target_level |
String |
Yes |
Definition: Target incident level. Constraints Length: 0 to 255 characters Range: N/A Default Value: N/A |
|
virtual_change_level_comment |
String |
Yes |
Definition: Remarks added during incident ticket escalation or de-escalation. Constraints Length: 0 to 255 characters Range: N/A Default Value: N/A |
|
Parameter |
Type |
Mandatory |
Description |
|---|---|---|---|
|
conclusion |
Boolean |
Yes |
Definition: Whether the change is agreed. The fixed value is true, indicating that the change is approved. Constraints N/A Range: true Default Value: N/A |
|
note |
String |
Yes |
Definition: Remarks added during incident ticket escalation or de-escalation review. Constraints Length: 0 to 1,024 characters Range: N/A Default Value: N/A |
|
Parameter |
Type |
Mandatory |
Description |
|---|---|---|---|
|
conclusion |
Boolean |
Yes |
Definition: Whether the change is agreed. The fixed value is true, indicating that the change is rejected. Constraints N/A Range: false Default Value: N/A |
|
note |
String |
Yes |
Definition: Remarks. Constraints Length: 0 to 1,000 characters Range: N/A Default Value: N/A |
|
Parameter |
Type |
Mandatory |
Description |
|---|---|---|---|
|
virtual_confirm_comment |
String |
Yes |
Definition: Remarks. Constraints Character length: 0 to 300 Range: N/A Default Value: N/A |
|
Parameter |
Type |
Mandatory |
Description |
|---|---|---|---|
|
mtm_region |
String |
No |
Definition: Region. Constraints Character length: 0 to 255 Range: N/A Default Value: N/A |
|
enterprise_project_id |
String |
Yes |
Definition: ID of the enterprise project to which the incident ticket is bound. You can query the enterprise project list through EPS. Constraints If the enterprise project is default, the value is 0. Range: N/A Default Value: N/A |
|
current_cloud_service_id |
String |
Yes |
Definition: Cloud service ID, which can be obtained by calling the API for Querying an Application. Constraints Character length: 0 to 255 Range: N/A Default Value: N/A |
|
level_id |
String |
Yes |
Definition: Incident level. For details, see Incident Level in the incident-related enumeration information. Constraints Character length: 0 to 255 Range: N/A Default Value: N/A |
|
is_service_interrupt |
Boolean |
Yes |
Definition: Whether the service is interrupted. Constraints N/A Range: true/false Default Value: N/A |
|
mtm_type |
String |
No |
Definition: Issue type. Constraints Character length: 0 to 255 Range: N/A Default Value: N/A |
|
title |
String |
Yes |
Definition: Title. Constraints Character length: 0 to 255 Range: N/A Default Value: N/A |
|
description |
String |
Yes |
Definition: Description. Constraints Character length: 0 to 600 Range: N/A Default Value: N/A |
|
attachments |
String |
No |
Definition: Attachment ID. Constraints Character length: 0 to 255 Range: N/A Default Value: N/A |
|
source_id |
String |
Yes |
Definition: Incident source. If the incident is manually created, the value is incident_source_manual. Constraints Character length: 0 to 255 Range: N/A Default Value: N/A |
|
incident_ownership |
String |
No |
Definition: Incident ownership. Constraints Character length: 0 to 255 Range: N/A Default Value: N/A |
|
start_time |
Long |
No |
Definition: Fault occurrence time. Constraints N/A Range: 1-9999999999999 Default Value: N/A |
|
assignee |
String |
No |
Definition: Incident handler. Constraints Character length: 0 to 255 If an incident handler exists, the handler is preferentially used. If no handler exists, the shift scenario and role cannot be empty. That is, the three fields cannot be empty at the same time. Range: N/A Default Value: N/A |
|
assignee_scene |
String |
No |
Definition: Shift scenario. Constraints Character length: 0 to 255 If an incident handler exists, the handler is preferentially used. If no handler exists, the shift scenario and role cannot be empty. That is, the three fields cannot be empty at the same time. Range: N/A Default Value: N/A |
|
assignee_role |
String |
No |
Definition: Shift role. Constraints Character length: 0 to 255 If an incident handler exists, the handler is preferentially used. If no handler exists, the shift scenario and role cannot be empty. That is, the three fields cannot be empty at the same time. Range: N/A Default Value: N/A |
Response Parameters
Status code: 200
|
Parameter |
Type |
Mandatory |
Description |
|---|---|---|---|
|
provider_code |
String |
No |
Definition: Service ID. Range: Character length: 0 to 256 Default Value: 049 |
|
error_code |
String |
No |
Definition: Request response code. The value ranges from 0000 to 9999. The value is 0 in normal cases. Range: Character length: 0 to 256 Default Value: 0 |
|
error_msg |
String |
No |
Definition: Response description for a request. Range: Character length: 0 to 256 Default Value: N/A |
Request Examples
- Do not accept the incident and transfer it to the owner.
POST https://{Endpoint}/v2/incidents/{incident_id}/action
{
"task_id": "{task_id}",
"action": "unAcceptedForward",
"params": {
"virtual_send_comment": "Remarks",
"virtual_current_location_info": "Location***",
"virtual_send_assignee": "bae47db0f86c48318ea65f10bd8aa417"
}
}
- Accept the incident and transfer it to the owner.
POST https://{Endpoint}/v2/incidents/{incident_id}/action
{
"task_id": "{task_id}",
"action": " acceptedForward",
"params": {
"virtual_send_comment": "Remarks",
"virtual_current_location_info": "Location***",
"virtual_send_assignee": "bae47db0f86c48318ea65f10bd8aa417"
}
}
- Accept the incident.
POST https://{Endpoint}/v2/incidents/{incident_id}/action
{
"task_id": "{task_id}",
"action": " accepted"
}
- Add remarks.
POST https://{Endpoint}/v2/incidents/{incident_id}/action
{
"task_id": "{task_id}",
"action": "addRemark",
"params": {
"note": Remarks"
}
}
- Process the incident.
POST https://{Endpoint}/v2/incidents/{incident_id}/action
{
"task_id": "{task_id}",
"action": "commitSolution",
"params": {
"mtm_type": "inc_type_p_middleware_issues",
"is_service_interrupt": false,
"start_time": null,
"fault_recovery_time": null,
"cause": "222",
"solution": "2222",
"resolve_attachments": ""
}
}
- Verify and close the incident.
POST https://{Endpoint}/v2/incidents/{incident_id}/action
{
"task_id": "{task_id}",
"action": "confirm",
"params": {
"virtual_confirm_result": true,
"virtual_confirm_comment": "Remarks"
}
}
- Apply for suspending the incident.
POST https://{Endpoint}/v2/incidents/{incident_id}/action
{
"task_id": "{task_id}",
"action": "incidentPause",
"params": {
"pause_end_time": 1744270013000,
"pause_reason": "Suspension reason"
}
}
- Approve the suspension application.
POST https://{Endpoint}/v2/incidents/{incident_id}/action
{
"task_id": "{task_id}",
"action": "agreed",
"params": {
"pause_approve_conclusion": true,
"note": Remarks"
}
}
- Reject the suspension application.
POST https://{Endpoint}/v2/incidents/{incident_id}/action
{
"task_id": "{task_id}",
"action": "rejected",
"params": {
"pause_approve_conclusion": false,
"note": "Review reason"
}
}
- Suspend or resume the incident.
POST https://{Endpoint}/v2/incidents/{incident_id}/action
{
"task_id": "{task_id}",
"action": " recovery"
}
- Apply for escalating or de-escalating the incident.
POST https://{Endpoint}/v2/incidents/{incident_id}/action
{
"task_id": "{task_id}",
"action": "changeLevel",
"params": {
"virtual_target_level": "level_30",
"virtual_change_level_comment": "[Service impact]: 2\n[Escalation or de-escalation reason]: 3333"
}
}
- Approve the escalation or de-escalation application.
POST https://{Endpoint}/v2/incidents/{incident_id}/action
{
"task_id": "{task_id}",
"action": "agreed",
"params": {
"conclusion": true,
"note": Remarks"
}
}
- Reject the escalation or de-escalation application.
POST https://{Endpoint}/v2/incidents/{incident_id}/action
{
"task_id": "{task_id}",
"action": "rejected",
"params": {
"conclusion": false,
"note": Remarks"
}
}
- Reject the incident that is submitted for acceptance.
POST https://{Endpoint}/v2/incidents/{incident_id}/action
{
"task_id": "{task_id}",
"action": "rejected",
"params": {
"virtual_confirm_comment": "Reason for rejection"
}
}
- Reject the incident and enable it again.
POST https://{Endpoint}/v2/incidents/{incident_id}/action
{
"task_id": "{task_id}",
"action": "ReOpen",
"params": {
"mtm_region": "br-cto-beta",
"enterprise_project_id": "0",
"current_cloud_service_id": "653f911cfab10c5b1dd33c3a",
"level_id": "level_40",
"is_service_interrupt": true,
"mtm_type": "inc_type_p_monitoring_issues",
"title": "22",
"description": "22",
"attachments": "",
"source_id": "incident_source_manual",
"incident_ownership": "incident_ownership_100",
"start_time": 1743674805160,
"assignee": "bae47db0f86c48318ea65f10bd8aa417",
"assignee_scene": "",
"assignee_role": ""
}
}
- Reject and close the ticket.
POST https://{Endpoint}/v2/incidents/{incident_id}/action
{
"task_id": "{task_id}",
"action": "agreed"
}
Response Examples
Status code: 200
Request result is returned.
For more status codes, see Status Codes.
{
"provider_code": "049",
"error_code": "GOM.00000000",
"error_msg": null
}
Status code: 400
The server failed to process the request.
For more status codes, see Status Codes.
{
"error_code" : "GOM.00007256",
"error_msg" : "Parameter error",
"provider_code" : "049",
"data" : null
}
Status Codes
|
Status Code |
Description |
|---|---|
|
200 |
Request result is returned. For more status codes, see Status Codes. |
|
400 |
The server failed to process the request. For more status codes, see Status Codes. |
Error Codes
For details, see Error Codes.
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