How Do I Handle OBS-related Errors Displayed in DataArts Studio? (General)
Symptom
- When DataArts Studio attempts to use an OBS bucket path, a message is displayed, indicating that the created OBS bucket is unavailable.
- "Error: stat:403" is reported when you perform operations on an OBS bucket.
- "Permission denied" is reported when a file is downloaded from OBS to Notebook.
Possible Cause
- The OBS bucket and DataArts Studio are in different regions.
- Access authorization has not been configured on DataArts Studio.
- Encrypted files are to upload to OBS. DataArts Studio does not support encrypted OBS files.
- The permissions and access control lists (ACLs) of the OBS bucket are incorrectly configured.
Solution
Check whether the OBS bucket and DataArts Studio are in the same region.
- Check the region where the created OBS bucket is located.
- Log in to the OBS console.
- On the Buckets page, enter the name of created OBS bucket in the search box or locate the bucket in the Bucket Name column.
In the Region column, check the region where the created OBS bucket is located.
- Check the region where DataArts Studio is deployed.
Log in to the DataArts Studio console and view the region where DataArts Studio is located in the upper left corner.
- Check whether the region of the created OBS bucket is the same as that of DataArts Studio. Ensure that they are the same.
Check agency authorization.
Go to the Permission Management page and check whether you have the OBS access permission. If you do not have the permission, see Configuring a Scheduling Identity.
Check whether the OBS bucket is not encrypted.
- Log in to the OBS management console and click the bucket name to go to the Overview page.
- Ensure that default encryption is disabled for the OBS bucket. If the OBS bucket is encrypted, click Default Encryption and disable it.
When you create an OBS bucket, do not select Archive or Deep Archive. Otherwise, tasks will fail.
Figure 1 Checking bucket encryption status
Check whether the OBS file is encrypted.
- Log in to the OBS management console and click the bucket name to go to the Overview page.
- In the navigation pane on the left, choose Objects. The object list is displayed. Click the name of the object that stores files and find the target file. In the Encrypted column of the file list, check whether the file is encrypted. File encryption cannot be canceled. In this case, cancel bucket encryption and upload images or files again.
Check the ACLs of the OBS bucket.
- Log in to the OBS management console and click the bucket name to go to the Overview page.
- In the navigation pane, choose Permissions and click Bucket ACLs. Then, check whether the current account has the read and write permissions. If it does not, contact the bucket owner to obtain the permissions.
- In the navigation pane on the left, choose Permissions > Bucket Policy, and check whether the current OBS bucket can be accessed by IAM users.
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