云耀云服务器(旧版)
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Windows云服务器访问公网不通应如何处理?
从Windows云服务器访问外部网络,遇到网络不通的情形,可参考本节内容进行排查。
可能原因
- 云服务器未分配公网IP。
- 弹性公网IP的带宽超限。
- 公网ISP运营商的劫持或者封堵。
- Windows云服务器的异常行为,导致安全策略禁止该机器的外网访问。
- Windows云服务器安全组配置不正确。
- Windows云服务器系统性能问题。
- Windows云服务器的防火墙阻拦。
- Windows云服务器安装了第三方杀毒软件,杀毒软件做了外网阻拦。
- Windows云服务器受病毒或木马影响。
- Windows云服务器网络配置错误。
处理方法
针对此问题,我们推荐采用以下方式来排查:
- 检查是否已经向云服务器实例绑定了公网IP,如果未绑定公网IP,请在绑定弹性公网IP后重试。
绑定弹性公网IP请参考绑定弹性IP。
- 云服务器绑定了弹性公网IP时,通过带宽提供公网和云服务器间的访问流量。
如果出现访问公网不通,请排查弹性公网IP带宽是否超过带宽最大上限。
排查带宽超限的方法请参考如何排查带宽超过限制?
- 检查是否仅仅是访问特定地址有问题,如果是特定地址有问题,则可能跟运营商封堵阻拦有关。
- 在云服务器的命令行窗口,使用ipconfig /all命令检查网卡配置是否正确。在命令行中输入ncpa.cpl打开网络共享与管理中心,检查网卡状态是否正常收发。
- 使用Route Print命令检查Windows云服务器的路由表,查看活动路由中的0.0.0.0默认路由是否指向默认网关。
- 使用ping命令检查云服务器与网关通信是否正常。
- 通过ping命令探测域名,可以获取域名对应IP地址。
对比ping域名和ping具体IP地址的时间差异,观察DNS服务器解析是否正常。
- 用netstat命令检查是否存在SYN-SENT、CLOSE_WAIT、FIN_WAIT。
若存在表明端口耗尽。一般是软件问题,排查解决问题后,需要重启云服务器进行恢复。
- 检查云服务器安全组是否有配置错误,安全组出方向规则为白名单(允许),放通出方向网络流量。例如图1所示,配置出方向允许所有访问。
可参考修改安全组规则配置,开放允许访问的协议或端口。
- 查看并禁用Windows云服务器防火墙策略,禁用后检查是否可以连通网络。
- 尝试禁用或者卸载Windows云服务器的第三方杀毒软件,检查问题是否发生。
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