Help Center/ Server Migration Service/ FAQs/ Disk Management/ Why Can't I Attach the Original System Disk Back to a Target Server?
Updated on 2025-07-30 GMT+08:00

Why Can't I Attach the Original System Disk Back to a Target Server?

Symptom

A migration failed, and you found that the target server still used the temporary system disk whose name started with SMS and its original system back could not be attached back.

Possible Causes

The temporary system disk was not detached. You need to manually detach the temporary disk.

Solution

This section uses Linux as an example to describe how to detach the temporary system disk and attach the original one back to the target server.

  1. Switch to the SMS-Agent directory on the source server, run ./agent-cli, enter connect, and press Enter to connect the source server to SMS.

  2. Run clear in the CLI.

    After about a minute, the temporary disk on the target server will be detached and deleted, and the original system disk will be attached back.

  1. Log in to the ECS console, locate the target server, and detach the temporary system disk. For details, see Detaching an EVS Disk from a Running ECS.
  2. Log in to the API Explorer.
  3. Set the following parameters:
    • Region: Select the target region.
    • Project_id: indicates the project ID, which is automatically filled after login. You can leave it blank.
    • server_id: indicates the ID of the server to which the system disk is to be attached.
    • device: indicates the disk mount point.
      • For Xen ECSs, device is mandatory. Set device to /dev/sda.
      • For KVM ECSs, set device to dev/vda.
    • volumeId: indicates the ID of the disk to be attached. The value is in UUID format.
    Figure 1 Attaching disks