What Should I Do If a Key Pair Created Using puttygen.exe Cannot Be Imported to the Management Console?
Symptom
When a key pair created using puttygen.exe was imported to the management console, the system displayed a message indicating that importing the public key failed.
Possible Causes
The format of the public key content does not meet system requirements.
Storing a public key by clicking Save public key of puttygen.exe will change the format of the public key content. Such a key cannot be imported to the management console.
Solution
Use the locally stored private key and PuTTY Key Generator to restore the format of the public key content. Then, import the public key to the management console.
- Double-click puttygen.exe to switch to the PuTTY Key Generator page.
Figure 1 PuTTY Key Generator
- Click Load and select the private key.
The system automatically loads the private key and restores the format of the public key content in PuTTY Key Generator. The content in the red box in Figure 2 is the public key with the format meeting system requirements.
- Copy the public key content to a .txt file and save the file in a local directory.
- Import the public key to the management console.
- Log in to the management console.
- Click
in the upper left corner and select your region and project. - Under Computing, click Elastic Cloud Server.
- In the navigation pane on the left, choose Key Pair.
- On the right side of the page, click Import Key Pair.
- Copy the public key content in the .txt file to Public Key Content and click OK.

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