Why Was My Login to a Linux ECS Using a Key File Unsuccessful?
Symptom
When the key file for creating a Linux ECS was used to log in to the ECS, the login failed.
Possible Causes
Possible causes vary depending on the image used to create the Linux ECS.
- Cause 1: The image used to create the Linux ECS is a private image, on which Cloud-Init is not installed.
- Cause 2: Cloud-Init is installed on the image, but the key pair was not obtained during ECS creation.
Solution
- If the issue is a result of cause 1, proceed as follows:
If a private image is created without Cloud-Init installed, the ECS configuration cannot be customized. As a result, you can log in to the ECS only using the original image password or key pair.
The original image password or key pair is the OS password or key pair configured when the private image was created.
If the original image password was forgotten or key pair has been lost, use the password reset function available on the Elastic Cloud Server page to reset the password.
- If the issue is a result of cause 2, proceed as follows:
- Locate the row containing the target ECS, click More in the Operation column, and select Restart.
- Use the key file to log in to the ECS again and check whether the login is successful.
- If the login is successful, no further action is required.
- If the login failed, contact customer service for technical support.
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