Help Center> Application Operations Management> FAQ> Usage FAQs> Why Can't I See Any Logs on the Console?

Why Can't I See Any Logs on the Console?

Symptom

No logs are displayed on the AOM console.

Possible Causes

  • ICAgent has not been installed.
  • The collection path is incorrectly configured.
  • You set the log collection to be stopped when the free quota is used up on the Application Operations Management (AOM) console.
  • You set the log collection to be stopped when the free quota is used up on the LTS console.
  • Log collection was stopped because your account is in arrears.
  • The rate of writing logs into log streams or length of single-line logs exceeds what is supported.
  • The browser has slowed down because of the amount of log data.

Solution

  • Install ICAgent. For details, see Installing ICAgent.
  • If the collection path is set to a directory, for example, /var/logs/, only .log, .trace, and .out files in the directory are collected. If the collection path is set to name of a file, ensure that the file is a text file. For details about log collection paths, see Configuring Log Collection Rules.
  • Log in to the AOM console and choose Configuration Management > Log Configuration. On the Quota Management tab, enable Continue to Collect Logs When the Free Quota Is Exceeded.
  • Log usage, including log read/write, log indexing, and log retention, is billed in LTS. If you have disabled Continue to Collect Logs When the Free Quota Is Exceeded on the LTS console, log collection will be stopped when the free quota is used up. Logs will not be able to be read, written, or indexed. No fees will be incurred for log read/write and indexing. To resume log collection, enable Continue to Collect Logs When the Free Quota Is Exceeded on the LTS console. For details, see Configuration Center.
  • Top up your account if your account is in arrears. For details, see Repaying Outstanding Amount.
  • For details about log usage restrictions, see Usage Restrictions.
  • Use Google Chrome or Mozilla Firefox to query logs.
  • If the issue persists after you have tried the methods above, submit a service ticket.