Windows云服务器网络QoS超限怎么办?
问题描述
使用 Windows 系统的弹性云服务器时,出现如下现象:
可能原因
带宽使用率较高可能有以下原因:
- 正常业务频繁访问,导致占用较高带宽。
- 恶意病毒、木马引起的网络流量。
有些情况下,第三方恶意程序可能会利用操作系统中的svchost.exe或tcpsvcs.exe进行伪装,从而导致以上被伪装进程的带宽使用率较高。
- Windows实例自身服务(例如:Windows Update服务)占用较高网络流量。
处理方法
- 登录弹性云服务器,具体操作,请参见Windows ECS登录方法概述。
- 使用工具进行定位。
可通过多种工具定位带宽使用率过高的问题,并且还可以通过Wireshark进行抓包,进一步分析流量数据包。
- 工具一:在搜索框搜索并打开“资源监视器”,选择“网络”页签,查看带宽使用率过高的进程。
若需要查看进程的详细信息,可以用任务管理器,在进程页签中,找到从资源管理器中识别到的异常进程,右键该进程选择属性、转到详细信息或打开文件位置,以此判断是否为恶意程序。
图1 资源监视器 - 工具二:如果在资源监视器中未发现带宽使用率较高的进程,但实例带宽使用率依然很高,很可能是因为外部服务在进行访问。
可以通过微软官方提供的TCPView工具进行分析。
- TCPView可以显示系统上所有TCP和UDP网络连接的详细列表,包括本地和远程地址以及TCP连接的状态,下载链接:TCPView。
- 双击打开即可查看网络带宽详情。
图2 TCPView
- 工具三:如需对流量数据包进行深入分析,可以通过Wireshark进行数据包的捕获与分析。
- 安装并打开Wireshark,下载地址:Wireshark。
- 选择“捕获 > 选项”,在捕获窗口根据接口名称或对应的IP地址选择需要进行抓包的网络,然后单击开始。
图3 捕获选项
- 在工具栏中选择“统计 > 会话”。
- 在会话窗口,可以看到所有网络通信,从链路层、IP层、TCP层分别给出了流量的具体情况和通信两端的流量情况。
- 通过抓取一段时间的网络包可以分析具体占用较高流量的连接、端口。
图4 网络包
- 工具一:在搜索框搜索并打开“资源监视器”,选择“网络”页签,查看带宽使用率过高的进程。
- 根据网络带宽使用情况进行处理。
- 场景一 异常用户程序/进程长时间占用大量网络资源,或非法IP地址恶意访问服务导致网络负载较高。
- 场景二:正常用户程序/进程长时间占用大量网络资源,或有指定IP地址访问服务导致网络负载较高。
- 检查后台是否有执行WIndows Update的行为。
- 升级实例带宽,详情可参考修改弹性公网IP的带宽。
若已经配置了最大带宽仍无法满足对带宽的需求,建议考虑进行应用分离,通过不同服务器承载各个应用服务,如可以用RDS承载数据库服务等。
- 单个业务程序/进程偶发网络资源占用较高,但持续时间较短且频率较低。此时需要优化业务程序,调整链接数、缓存配置及数据库配置参数等应用配置参数。
- 若没有单个程序/进程占用网络资源,但整体网络负载较高时,说明业务正常运行所需网络资源性能大于当前网络带宽,可进行带宽升级操作,详情可参考修改弹性公网IP的带宽。