文档首页 > > 开发指南> HDFS应用开发> 环境准备> 获取并导入样例工程

获取并导入样例工程

分享
更新时间: 2020/03/16 GMT+08:00

操作场景

HDFS针对多个场景提供样例工程,帮助客户快速学习HDFS工程。

以下操作步骤以导入HDFS样例代码为例。

操作步骤

  1. 参照样例工程获取地址,下载样例工程到本地。
  2. 导入样例工程到Eclipse开发环境。

    1. 第一种方法:打开Eclipse,选择“File > New > Java Project”
    2. 去掉对“Use default location”的勾选,单击“Browse”

      显示“浏览文件夹”对话框。

    3. 选择样例工程文件夹hdfs-examples,单击“确定”
    4. “New Java Project”窗口单击“Finish”
    5. 第二种方法:打开Eclipse,依次选择“File > Import… > Existing maven Projects into Workspace > Next”,在下一个页面单击“Browse”,显示“浏览文件夹”对话框。
    6. 选择样例工程文件夹“hdfs-examples”,单击“确定”
    7. “Import”窗口单击“Finish”

  3. 设置Eclipse的文本文件编码格式,解决乱码显示问题。

    1. 在Eclipse的菜单栏中,选择“Window > Preferences”。

      弹出“Preferences”窗口。

    2. 在左边导航上选择“General > Workspace”,在“Text file encoding”区域,选中“Other”,并设置参数值为“UTF-8”,单击“Apply”后,单击“OK”,如图1所示。
      图1 设置Eclipse的编码格式

分享:

    相关文档

    相关产品

文档是否有解决您的问题?

提交成功!

非常感谢您的反馈,我们会继续努力做到更好!

反馈提交失败,请稍后再试!

*必选

请至少选择或填写一项反馈信息

字符长度不能超过200

提交反馈 取消

如您有其它疑问,您也可以通过华为云社区问答频道来与我们联系探讨

智能客服提问云社区提问