访问Windows应用发布器,提示“创建用户失败”怎么办?
问题现象
发布Windows应用之后,应用运维单击登录,报错信息:访问Windows应用发布失败,提示”创建用户失败“。
可能原因
- 原因一:应用发布服务器中安装的RemoteAppProxy跳板工具版本过低,需要升级。
- 原因二:创建影子账户用户名最大长度和服务器账户最大长度冲突。
解决办法
- 解决办法一:将应用发布服务器安装的remoteapp组件升级至1.1.8.0及以上版本。
- 解决办法二:登录应用发布服务器,修改“C:\DevOpsTools\RemoteAPPProxy\Application.ini”文件,修改参数影子账户用户名最大长度max_user_length=20将值改为服务器支持的创建用户长度,例如15。
若您不想通过升级RemoteAppProxy跳板工具的临时处理方法,可登录应用发布服务器修改“C:\DevOpsTools\RemoteAPPProxy\Application.ini”文件,修改参数,关闭影子账户:use_shadow_user=0
是否使用影子账户模式的参数说明:
- 1:开启
- 0:关闭