上传/下载文件失败怎么办?
通过Web运维上传下载失败
问题现象
- 下载“云主机文件”到“主机网盘”,即下载文件到用户个人主机网盘时,提示下载失败错误。
- 上传文件失败,提示“/3.0/h5FileService/upload-403:服务错误,请稍后重试”。
- 从本地上传文件到“主机网盘”,即上传到用户个人主机网盘时,提示“个人网盘空间不足,请清理网盘或联系管理员增加网盘空间”或“网盘存储空间不足”。
- 上传/下载大文件失败。
- 客户使用debian+rdp协议上传文件失败。
- 客户使用zoc客户端工具上传文件失败。
排查思路及解决办法
| 排查步骤 | 可能的原因 | 解决办法 |
|---|---|---|
| 排查堡垒机的版本是否是最新的版本 | 堡垒机版本太低 | 对堡垒机进行升级,具体操作请参见升级版本。 |
| 排查待上传/下载的文件是否打包成压缩文件 | 堡垒机不支持下载文件夹, 需要把文件夹打包成压缩文件才可以上传/下载。 | 把文件夹打包成压缩文件,再进行上传/下载。 |
| 排查是否配置了上传/下载权限 | 未开启资源“文件管理权限”,也未授权用户“文件管理”的上传/下载权限。 | |
| 排查浏览器的缓存空间 | 浏览器的缓存空间不足 | 用户手动清理浏览器缓存空间后,再次上传。 |
| 排查“个人网盘空间”是否还有可存储容量 | “个人网盘空间”即磁盘,不支持自动定期清理,“个人网盘空间”容量小,个人网盘空间不足,系统剩余可用磁盘存储空间不足。 | |
| 排查上传/下载的文件是否太大 | 上传/下载的文件太大 | |
| 排查Web登录超时时间配置是否不合理 | 上传/下载大文件耗时较长,且Web登录连接超时,导致上传/下载超大文件失败。 | |
| 排查客户端使用的协议和上传工具是否与云堡垒机兼容 | 云堡垒机暂不支持debian+rdp协议和zoc工具上传/下载文件。 | 使用云堡垒机支持的协议以及对应的客户端工具上传/下载文件:
|
| 排查主机SCP命令是否正常可用 | 未安装SCP | 需要在ECS的服务器配置中安装SCP。 |
通过SSH客户端运维上传/下载失败
问题现象
在Xshell客户端上,登录云堡垒机运维SSH协议主机资源,不能正常调用Xftp客户端传输文件。
可能原因
云堡垒机SSH客户端运维限制调用工具进行文件传输,即SSH客户端运维不支持文件传输功能和审计传输的文件。
解决办法
- 重新配置一个同“主机地址”的FTP/SFTP协议主机资源,通过FTP/SFTP客户端运维进行文件传输。
例如,配置SFTP协议主机资源并授权访问控制权限后,直接在Xftp客户端上,登录云堡垒机运维配置的主机资源,即可实现上传/下载文件。
- 通过Web运维SSH协议主机资源,实现上传/下载文件操作。
更多Web运维文件传输说明,请参见通过Web运维,如何上传/下载文件?。
更多SSH协议主机资源文件传输说明,请参见SSH协议主机如何使用FTP/SFTP传输文件?
如果通过上述排查,仍然无法上传/下载文件,请单击控制台右上方的“工单”,填写工单反馈问题现象,联系技术支持。