文档首页> 智能边缘平台 IEF> 服务公告> 边缘节点版本支持公告
更新时间:2021-12-01 GMT+08:00
分享

边缘节点版本支持公告

为了能够更好地方便您使用智能边缘平台服务,确保您的边缘节点稳定可靠的接入智能边缘平台,IEF推出智能边缘平台软件版本支持机制,将支持发布周期一年内版本的维护,请您务必在维护周期结束之前升级您的边缘节点软件(EdgeCore)版本。

版本命名规范

边缘节点软件版本采用GNU软件版本命名规范:主版本号.子版本号.修正版本号,例如2.22.0

  • 主版本号:一般在软件有重大升级时增长
  • 子版本号:一般在软件有新功能时增长
  • 修正版本号:一般在软件有问题修复后增长

版本支持策略

IEF只负责维护发布周期一年内的边缘节点软件版本,建议您的边缘节点每年至少升级一次。

版本升级规范

边缘节点升级时,智能边缘平台自动选择最新版本的EdgeCore在边缘节点进行升级。

例如,当前EdgeCore有2.22.0、2.23.0、2.24.0三个版本,而您的边缘节点上EdgeCore版本为2.12.0,当您升级边缘节点时,IEF将推送最新版本2.24.0给您的边缘节点进行升级。

注意事项

  • 为了让您的边缘节点应用更稳定可靠的运行,IEF不会主动升级您的边缘节点上的EdgeCore,需要由您在业务影响最小的时间窗内进行节点升级,以减轻对您业务的影响。
  • 处于维护周期中的版本升级,边缘节点上的应用业务不会中断,如果您有使用消息路由功能,可能会有短暂影响。
  • 处于维护周期外的版本升级,可能会因为容器重启引起业务的短暂中断。
  • 请勿在节点升级过程中变更节点配置,比如重启Docker、安装卸载GPU/NPU驱动、OS内核升级、变更网络配置等,这些操作会增大节点升级失败风险。

升级方法

请参见升级边缘节点

历史版本

版本号

发布日期

版本说明

维护状态

2.53.0

2021/11/04

【新增】IEF预置告警和自定义告警支持配置告警可能原因以及修复建议

【新增】支持边缘核心软件EdgeCore配置管理

维护中

2.52.1

2021/07/22

【修复】2.52.0版本发现的一些问题

维护中

2.52.0

2021/06/03

【修复】边缘节点软件版本为2.7.0时,升级至最新版本后业务容器无法启动问题

维护中

2.51.1

2021/04/20

【新增】更新GPU节点驱动安装方式,支持用户离线安装GPU驱动

【修复】2.51.0版本发现的D910问题

须知:

GPU节点更新至此版本时,请参考拷贝GPU驱动文件进行环境准备。

维护中

2.51.0

2021/02/25

【修复】2.24.0版本发现的一些问题

维护中

2.24.0

2020/10/21

【新增】支持edgemesh会话保持(一致性hash分发)能力

【修复】2.23.0版本发现的一些问题

过期版本,请升级

2.23.0

2020/08/26

【新增】支持边缘节点间分布式健康监测与自主调度

【新增】支持边缘通道tls双向认证

【修复】2.22.0版本发现的一些问题

过期版本,请升级

2.22.0

2020/07/11

【新增】边缘软件K8S版本升级至1.15

【新增】边缘侧密钥数据加密存储

【优化】边缘软件轻量化

【修复】2.21.0版本发现的一些问题

过期版本,请升级

2.21.0

2020/05/18

【新增】支持对容器所在磁盘使用率的检测

【修复】修复应用删除过程中EdgeCore重启导致应用无法删除的问题

过期版本,请升级

2.20.0

2020/04/18

【新增】Davinci芯片型号、驱动版本、内存等信息采集

【新增】铂金版edgemesh功能提供

【修复】2.12.0版本发现的一些问题

过期版本,请升级

2.12.0

2019/11/01

【修复】Ubuntu 18.04边缘节点容器域名无法解析问题

过期版本,请升级

2.11.0

2019/10/30

【优化】边缘软件性能优化

【修复】2.10.0版本发现的一些问题

过期版本,请升级

2.10.0

2019/10/24

【新增】支持应用升级镜像预下载与镜像加速

【修复】2.9.0版本发现的一些问题

过期版本,请升级

2.9.0

2019/10/16

【新增】支持Atlas 500 IEF模式和FD模式共部署

【修复】2.8.0版本发现的一些问题

过期版本,请升级

2.8.0

2019/10/09

【新增】支持多容器、pause容器、对接CRI

【新增】支持边缘节点唯一性校验,避免重复纳管

【修复】2.7.2版本发现的一些问题

过期版本,请升级

2.7.2

2019/08/17

【修复】2.7.1版本发现的一些问题

过期版本,请升级

2.7.1

2019/08/12

【新增】支持通过proxy上报告警

【修复】2.7.0版本发现的一些问题

过期版本,请升级

2.7.0

2019/07/29

【新增】支持AK/SK无效及应用重启告警

【修复】2.6.2版本发现的一些问题

过期版本,请升级

2.6.2

2019/07/26

【修复】2.6.1版本发现的一些问题

过期版本,请升级

2.6.1

2019/07/20

【新增】支持Atlas 500智能小站固件升级能力

【新增】支持边缘节点故障检测

过期版本,请升级

2.6.0

2019/07/11

【新增】铂金版实例节点组及节点组证书支持

【修复】2.5.0版本发现的一些问题

过期版本,请升级

2.5.0

2019/06/29

【新增】支持边缘节点hostip环境变量注入容器

【新增】Atlas 500智能小站纳管

【新增】支持command健康检查方式

【修复】2.4.0版本发现的一些问题

过期版本,请升级

2.4.0

2019/06/22

【新增】容器重启能力

【优化】应用删除逻辑,减少应用删除耗时

过期版本,请升级

2.3.2

2019/05/30

【修复】2.3.1版本发现的一些问题

过期版本,请升级

2.3.1

2019/05/23

【修复】2.3.0版本配置proxy后健康检查失败问题

过期版本,请升级

2.3.0

2019/05/10

【新增】支持Docker安装异常、应用存活探针异常、申请GPU资源失败等告警对接AOM

【新增】支持边缘加密数据

【新增】支持边缘时序数据库

【修复】2.2.7版本发现的一些问题

过期版本,请升级

2.2.7

2019/04/19

【新增】支持EventBus路由消息

【新增】支持边云消息压缩传输

【新增】支持通过proxy访问云端

【修复】2.2.6版本发现的一些问题

过期版本,请升级

2.2.6

2019/04/11

【新增】支持MQTT broker

【修复】2.2.5版本发现的一些问题

过期版本,请升级

2.2.5

2019/03/21

【新增】多K8S集群能力支持

过期版本,请升级

2.2.3

2019/03/20

【修复】节点长时间断连重启后节点故障问题

过期版本,请升级

2.2.2

2019/03/15

【新增】支持节点固件升级

过期版本,请升级

2.2.1

2019/03/07

【修复】2.2.0版本发现的一些问题

过期版本,请升级

2.2.0

2019/02/26

【新增】边缘节点证书加密

【新增】支持边缘获取临时AK/SK功能

过期版本,请升级

2.1.7

2019/01/25

【修复】2.1.6版本发现的一些问题

过期版本,请升级

2.1.6

2019/01/22

【修复】2.1.5版本发现的一些问题

过期版本,请升级

2.1.5

2019/01/03

【修复】2.1.3版本发现的一些问题

过期版本,请升级

2.1.3

2018/12/21

【新增】GPU型号、显存等信息展示

【修复】2.1.2版本发现的一些问题

过期版本,请升级

2.1.2

2018/12/07

【修复】2.1.1版本发现的一些问题

过期版本,请升级

2.1.1

2018/12/06

【修复】2.1.0版本发现的一些问题

过期版本,请升级

2.1.0

2018/12/01

【新增】容器启动失败ErrorMsg展示

【新增】Servicebus请求文件的最大限制

【修复】Docker未安装边缘节点异常问题

过期版本,请升级

2.0.3

2018/11/26

【修复】2.0.2版本发现的一些问题

过期版本,请升级

2.0.2

2018/11/21

【新增】Servicebus能力

【新增】容器端口与主机端口映射能力

【修复】2.0.1版本发现的一些问题

过期版本,请升级

2.0.1

2018/11/08

【修复】2.0.0版本发现的一些问题

过期版本,请升级

2.0.0

2018/10/31

EdgeCore 2.0.0版本发布,提供节点管理、容器管理、消息路由等功能

过期版本,请升级

分享:

    相关文档

    相关产品

close