更新时间:2023-05-29 GMT+08:00
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【Hue WebUI】Hue WebUI页面无法访问

现象描述

Hue服务组件的Hue WebUI页面打不开。

原因分析

  • 端口未对外开放。
  • 浮动IP配置错误。
  • 一次性查询大量的数据,导致查询耗时长,占用了Hue中Hive的链接,导致Hue访问出现异常。

排查思路

  1. 在浏览器所在的本地机器,通过命令行执行telnet指令,查看端口是否开放。
  2. 在Hue所在节点执行ifconfig,查看配置的浮动IP是否生效。
  3. 恢复该故障大概需要10分钟。
  4. 检查是否一次性查询了大量的数据。

处理步骤

  1. 登录FusionInsight Manager管理界面。
  2. 选择“集群 > 待操作集群的名称 > 服务 > Hue > 实例”,查看Hue服务主备是否正常。

    • 是,执行7
    • 否,执行3

  3. 单击“配置”,检查Hue配置项“HUE_FLOAT_IP”和“HTTP_PORT”是否正确。

    • 是,执行4
    • 否,修改正确的Hue服务浮动IP地址与端口。

  4. 在业务网络执行telnet HUE节点IP HTTP_PORT或者telnet HUE_FLOAT_IP HTTP_PORT,检查端口是否对外开放。

    • 是,检查端口是否正确,重新尝试登录页面。
    • 否,执行5

  5. 选择“集群 > 待操作集群的名称 > 服务 > Hue”,单击“停止服务”。
  6. root用户登录管理节点,执行ping HUE_FLOAT_IP,检查是否可以ping通。

    • 是,浮动IP已被使用,请重新配置其他IP地址。
    • 否,执行7

  7. 检查是否一次性查询了大量的数据。

    • 是,优化Hue查询,避免一次性查询大量数据。
    • 否,执行8

  8. 联系运维人员。

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