镜像预热异常如何处理
问题描述
镜像预热状态为异常。
问题原因
- 用户未配置SWR Administrator权限,将导致镜像预热失败。建议用户配置SWR Administrator权限。
- 配置镜像预热任务后,如果在一段时间内无法完成预热,将导致镜像预热进入超时异常状态。建议排查是否选择镜像过大或者SWR服务与资源池节点间的网络通信速率异常。
- 受节点磁盘docker分区的存储空间大小限制,当资源池节点docker分区剩余磁盘空间不足且镜像预热任务的镜像过大或者数量过多时,可能触发k8s镜像老化,阈值随机删除节点上未使用的空闲镜像,导致一个或多个镜像预热任务产生异常。
解决方法
对于docker分区磁盘空间不足且待预热的镜像较大、多个镜像预热任务异常的问题,建议先删除异常状态的镜像,然后根据优先级依次预热镜像,等待镜像预热任务成功后,再预热下一个镜像,避免同时预热多个大镜像互相影响。
异常码说明
| 异常码 | 错误信息 | 描述 | 处理措施 |
|---|---|---|---|
| 301 | 镜像预热任务异常,镜像不存在。 | 镜像预热任务异常,镜像不存在。 当节点上docker镜像磁盘空间不足时,触发k8s镜像老化后导致已预热的镜像被删除。 | 请确保节点存在足够的磁盘空间进行镜像预热,或者在镜像预热后,及时部署作业使用该镜像,以避免k8s镜像老化空闲镜像。 |
| 302 | 镜像预热任务超时。 | 镜像预热任务超时。 | 请检查待预热镜像是否过大或SWR服务镜像下载速率是否过低。 |
| 303 | 镜像拉取失败。 | 镜像拉取失败,原因未知。 | 请联系技术人员。 |
| 311 | 未在镜像仓库中查询到指定镜像,镜像预热任务执行异常。 | 未在镜像仓库中查询到指定镜像,镜像预热任务执行异常。 | 请检查镜像地址是否在镜像仓库中。 |