9200端口访问失败
问题现象
通过VPN专线或VPC的对等连接访问CSS集群的场景下,使用curl命令接入Elasticsearch集群时,无返回结果。
例如,执行如下命令接入集群,无返回结果。
curl -s 'http://<节点内网访问地址>:9200'
原因分析
在“使用VPN专线访问CSS集群”或“通过VPC的对等连接访问CSS集群”场景下,其所在的客户端与CSS不在同一VPC下。因此,要求CSS集群的子网与其VPC具有不同的网段。
例如,某一CSS集群,选用的VPC为“vpc-8e28”,其网络配置为“192.168.0.0/16”。选用了此VPC下的子网“subnet-4a81”,“subnet-4a81”子网的网段与“vpc-8e28”一致,均为“192.168.0.0/16”。此时,如果使用VPN专线访问CSS集群或通过VPC的对等连接访问CSS集群,会导致此子网创建的机器内没有该VPC对应的网关,从而影响CSS服务的默认路由的设置,最终导致9200端口访问失败。
处理步骤
当出现9200端口访问失败错误时,且CSS集群状态为可用状态,则可以参考如下步骤修复故障。
- 登录云搜索服务管理控制台。
- 在左侧导航栏,选择“集群管理”,根据目标集群选择集群类型,进入集群列表页面。
- 在集群列表,单击目标集群名称,进入集群详情页。
- 选择“概览”页签。
- 在配置信息模块,查看集群使用的“虚拟私有云”和“当前子网”。
- 单击虚拟私有云名称,进入VPC详情页面。查看VPC和子网的网段信息。
- 如果出现上述错误,请重新创建集群,并选择一个网段与VPC不同的子网,如不存在这样的子网,请在VPC管理控制台重新创建一个子网。
创建新的CSS集群后,将旧集群的数据迁移至新集群中,然后再通过VPN专线访问或使用VPC对等连接访问使用。
如果需要VPN专线访问或使用VPC对等连接访问CSS集群时,请务必保证,新创建的CSS集群,其VPC与子网,具备不同的网段信息。