更新时间:2022-04-01 GMT+08:00
分享

硬件规格

IoT边缘服务是软件,需要部署在硬件上,支持两种硬件规格,一种是容器化,一种是非容器化(进程级),其硬件规格和运行环境要求如表1表2所示。

表1 硬件规格要求

硬件参数

容器化参数要求(Docker环境)

进程级参数要求(非Docker环境)

OS

  • x86_64架构

    EulerOS 2.3

    Ubuntu 16.04

    Ubuntu 18.04

    CentOS 7.6

  • arm64架构

    EulerOS 2.8

    Ubuntu 18.04

Linux 32位/64位

资源控制只支持cgroup v1

CPU

≥ 1VCPU(起步规格)

≥ 1VCPU(起步规格)

RAM

≥ 256MB(1U2G支持100Tips,8U16G支持1000Tips)

≥ 128MB (1U256M支持500Tips)

磁盘

≥ 2GB

≥ 1GB

表2 硬件操作系统的环境要求

依赖项

容器化规格(Docker环境)

进程级规格(非Docker环境)

Docker

Docker版本必须高于17.06,推荐使用18.06.3版本。

(请勿使用18.09.0版本Docker,该版本存在严重bug,详见https://github.com/docker/for-linux/issues/543;如果已使用此版本,请尽快升级。Atlas 500小站预置的Docker 18.09.0.60软件版本已经修改该问题。)

Docker安装方法请参见https://docs.docker.com/install/overview/

可以选择使用开源的Docker CE或者使用Docker企业版(Docker EE),使用Docker EE时,需要支付Docker额外费用,更多Docker EE相关细节请参考Docker官方文档:https://docs.docker.com/ee/supported-platforms/

须知:
Docker安装完成后,请将Docker进程配置为开机启动,避免系统重启后Docker进程未启动引起的系统异常。

不涉及

glibc

版本不低于2.17,Linux默认自带,如需下载,参见官网链接

版本不低于2.17,Linux默认自带,如需下载,参见官网链接

wget

版本不低于1.10,Linux默认自带,如需下载,参见官网链接

版本不低于1.10,Linux默认自带,如需下载,参见官网链接

openssl

版本不低于1.0.2,Linux默认自带,如需下载,参见官网链接

版本不低于1.0.2,Linux默认自带,如需下载,参见官网链接

端口使用

边缘节点需要使用如下端口,请确保这些端口能够正常使用。

  • 7883:提供节点南向mqtt设备接入
  • 8943:提供边缘节点应急console访问

边缘节点需要使用如下端口,请确保这些端口能够正常使用。

  • 7883:提供节点南向mqtt设备接入
  • 8943:提供边缘节点应急console访问

NTP(可选)

可靠的授时服务器,要求误差不大于5秒。

不涉及

分享:

    相关文档

    相关产品

关闭导读