更新时间:2022-05-16 GMT+08:00
分享

约束与限制

边缘节点规格要求

边缘节点既可以是物理机,也可以是虚拟机。边缘节点需要满足表1的规格要求。

表1 边缘节点要求

项目

规格

OS

操作系统语言必须切换至英文

  • x86_64架构

    Ubuntu LTS (Xenial Xerus)、Ubuntu LTS (Bionic Beaver) 、CentOS、EulerOS、RHEL、银河麒麟、中兴新支点、中标麒麟

  • armv7i(arm32)架构

    Raspbian GNU/Linux (stretch)

  • aarch64(arm64)架构

    Ubuntu LTS (Bionic Beaver)、CentOS、EulerOS

内存

边缘软件开销约128MB,为保证业务的正常运行,建议边缘节点的内存大于256MB。

CPU

>= 1核

硬盘

>= 1GB

GPU(可选)

同一个边缘节点上的GPU型号必须相同。

说明:

当前支持Nvidia Tesla系列P4、P40、T4等型号GPU。

含有GPU硬件的机器,作为边缘节点的时候可以不使用GPU。

如果边缘节点使用GPU,您需要在纳管前安装GPU驱动。

NPU(可选)

华为昇腾AI加速处理器。

说明:

当前仅支持集成了华为昇腾310、710、910芯片的边缘节点,如Atlas 300推理卡、Atlas 500智能小站、Atlas 800推理服务器。

如果边缘节点使用NPU,请确保边缘节点已安装驱动(目前昇腾310仅支持1.3.x.x和1.32.x.x的固件版本,例如1.3.2.B893,可用npu-smi info命令查看固件版本)。如果没有安装驱动,请联系设备厂商获取支持。

容器引擎

Docker版本必须高于17.06,推荐使用18.06.3版本。

(请勿使用18.09.0版本Docker,该版本存在严重bug,详见https://github.com/docker/for-linux/issues/543;如果已使用此版本,请尽快升级。Atlas 500小站预置的Docker 18.09.0.60软件版本已经修改该问题。)

须知:

Docker安装完成后,请将Docker进程配置为开机启动,避免系统重启后Docker进程未启动引起的系统异常。

Docker Cgroup Driver必须设置为cgroupfs。

glibc

版本必须高于2.17。

端口使用

边缘节点需要使用8883端口,8883端口用于边缘节点内置MQTT broker监听端口,请确保该端口能够正常使用。

时间同步

边缘节点时间需要与UTC标准时间保持一致,否则会导致边缘节点的监控数据、日志上传出现偏差。您可以选择合适的NTP服务器进行时间同步,从而保持时间一致。详细配置方法请参见如何同步NTP服务器?

MQTT使用限制

表2 MQTT使用限制

描述

限制

支持的MQTT协议版本

3.1.1

与标准MQTT协议的区别

  • 支持QoS 0
  • 支持Topic自定义
  • 不支持QoS 1和QoS 2
  • 不支持will、retain msg

MQTTS支持的安全等级

采用TCP通道基础 + TLS协议(TLSV1.2 版本)

分享:

    相关文档

    相关产品

close