删除对象失败
问题描述
无法删除已上传的OBS对象。
排查思路
以下排查思路根据原因的出现概率进行排序,建议您从高频率原因往低频率原因排查,从而帮助您快速找到问题根因。
如果处理完某个可能原因仍未解决问题,请继续排查其他可能原因。
可能原因 |
处理措施 |
---|---|
本地网络故障 |
检查本地与OBS之间的网络是否正常,如果存在网络故障,解决网络故障,确保网络正常。 |
无删除对象的权限 |
请参考检查是否有删除对象的权限。 |
对象所属桶已启用多版本控制 |
请参考在“已删除对象”列表彻底删除对象。 |
“已删除对象”页签中WORM对象的保留策略在保留期内 |
|
其他原因 |
请参考提交工单。 |
检查是否有删除对象的权限
删除对象时报错“您没有执行此操作的权限。请联系您的管理员开通权限。”
- 确认桶ACLs是否有删除桶内对象的权限。
- 给对应类型的用户添加写入权限。
- 单击右边的“编辑”操作。
- 在弹窗内勾选“桶访问权限 > 写入权限”。
- 单击“确定”。
图2 添加写入权限
- 联系桶拥有者,确认桶策略是否已授予DeleteObject(删除对象)或DeleteObjectVersion(删除特定版本的对象)权限。
- 如果未授予上述权限,请联系桶拥有者授权。
- 如果已授予上述权限,仍然无法删除对象,请提交工单寻求更多帮助。
在“已删除对象”列表彻底删除对象
对象所属桶已启用多版本控制时,在“对象”列表删除对象,对象会迁移至“已删除对象”列表中,需要彻底删除避免产生计费。
如果待彻底删除的对象为保留策略在保留期内的WORM对象,请参考彻底删除保留策略在保留期内的WORM对象处理。
- 确认对象所属桶是否启用多版本控制。
- 在OBS控制台桶列表单击待操作的桶,进入“对象”页面。
- 在左侧导航栏单击“概览”,进入“概览”页面。
- 在“基础配置”区域查看“多版本控制”状态。
图3 查看多版本控制的状态
- 如果状态为已启用,此时请继续下一步。
- 如果状态为暂停或未启用,此时仍然无法删除对象,请提交工单寻求更多帮助。
- 彻底删除对象。
- 单击“已删除对象”页签,进入已删除对象列表。
- 在待删除对象的操作列单击“彻底删除”。
- 单击“确定”。
图4 彻底删除对象
彻底删除保留策略在保留期内的WORM对象
在“已删除对象”页签中,待彻底删除的对象为保留策略在保留期内的WORM对象,请等待保留策略过期,即可删除对象。删除操作请参见手动彻底删除WORM对象或配置生命周期规则删除WORM对象。
查看WORM对象保留期状态方式:进入“对象详情 > 版本”页签,找到当前版本对象,单击“更多 > 延长保留期”,即可参考下文查看保留期状态。
- WORM对象的保留策略在保留期内:在弹窗内可查看版本对象保留期的提示,如图6 WORM对象的保留策略在保留期内所示。
- WORM对象的保留策略已过期:在弹窗内可查看版本对象已过期天数的提示,如图7 WORM对象的保留策略已过期所示。
- WORM对象未配置保留策略:在弹窗内无法查看版本对象是否在保留期内,如图8 WORM对象未配置保留策略所示。
桶和对象相关 所有常见问题
- 创建桶失败
- 上传对象失败
- 下载对象失败
- 删除桶失败
- 删除对象失败
- 通过URL访问对象失败
- 桶存储类别和对象存储类别有什么关系?
- 我可以修改对象名称吗?
- 我可以修改桶所在的区域吗?
- 我可以在桶间进行文件复制吗?
- 我可以在桶间进行文件移动吗?
- 我可以在线编辑OBS中的对象吗?
- 如何获取对象访问路径?
- 无法搜索到桶中对象
- 如何在浏览器中在线预览OBS中的对象?
- 使用IE浏览器访问带有中文字符的对象URL地址报错如何处理?
- CDN加速场景下访问OBS桶内对象变成强制下载
- 为什么配置了跨域资源共享(CORS)仍然报错?
- 如何查看桶内的文件夹大小?
- 如何批量删除桶中大量对象或清空桶?
- 如何修改桶所属的企业项目?
- 如何上传超过5GB的大对象?
more