ALM-4287373398 启动失败回滚告警
告警解释
ENTITYTRAP/1/SYSTEMROLL:OID [oid] System rollback.(Reason="[OCTET]",Version ="[OCTET]",FileName="[OCTET]")
系统发生回滚。
告警属性
告警ID |
OID |
告警级别 |
告警类型 |
---|---|---|---|
4287373398 |
1.3.6.1.4.1.2011.5.25.219.2.11.3 |
紧急 |
处理出错告警 |
告警参数
参数名称 |
参数含义 |
---|---|
OID |
该告警所对应的MIB节点的OID号。 |
Reason |
错误码。
|
Version |
回滚前的版本号。 |
FileName |
文件名。 |
对系统的影响
系统软件启动后,仅支持当前版本软件的业务特性。
系统不支持恢复告警,需要用户手动处理清除此告警。
可能原因
- 系统软件升级或者整机重启时,设置的启动软件启动失败,系统就会试图用上次正常启动的软件启动。启动起来后发送此告警,提示本次软件是由于回滚启动。如果仍然不能启动,系统会再试图从设定的备份软件启动。启动起来后会发送此告警,提示本次软件是由于回滚启动。
- Flash故障,系统从Flash备份区启动,需要用户修复Flash。
- 控制器下发升级失败。
处理步骤
- 若系统发生回滚的原因为“System software rollback”,即系统软件回滚,请按以下步骤处理:
- 使用命令dir检查文件系统。
- 如果显示存储介质不可用,说明是存储介质损坏。请执行步骤2。
- 如果看到未能启动的软件还在文件系统里,则检查文件的大小,如果文件大小不符合正常范围,说明该系统软件是无效文件。请执行步骤3。
- 如果前两项结果都正常,说明系统软件有问题,不能启动。请执行步骤4。
- 查看系统软件存放的存储介质。
- 如果存储介质是SD卡或U盘,请更换SD卡或U盘,并重新进行升级。如果升级还是失败,请执行步骤4。
- 如果存储介质是Flash,请记录设备型号并请收集告警信息和配置信息,并联系技术支持人员。
- 删除此无效文件,重新上传一份完整的文件,并再执行升级操作。如果升级还是失败,请执行步骤4。
- 收集以上步骤的执行结果,并请收集告警信息和配置信息,并联系技术支持人员。
- 使用命令dir检查文件系统。
- 若系统发生回滚的原因为“Backup flash space rollback”,即系统从Flash备份区启动,需要用户修复Flash,请按以下步骤处理:
- 在用户视图下执行display startup命令查看设备当前启动的系统软件、配置文件等信息,回显中显示本次启动使用的系统软件或配置文件的存储路径为“backup:/”,表明系统从备份区启动。
- 在用户视图下执行format flash:命令格式化Flash存储器根目录。
执行此命令后,会清空指定存储器中的所有文件和目录,并且不可恢复,请谨慎使用。
- 格式化完成后,执行cd flash:命令将设备上用户当前的工作路径修改为flash:。然后通过SFTP方式将设备需要加载的系统软件和配置文件上传至Flash。
- 文件上传成功后,执行startup system-software system-file [ slave-board | all ] [ verify | signature sign-filename ]命令,配置系统下次启动时使用的系统软件。
- 执行startup saved-configuration configuration-file [ slave-board | all ]命令,配置系统下次启动时使用的配置文件。
- 配置完成后,重启设备后查看是否再次出现系统从备份区启动的告警。若仍存在,请联系技术支持人员处理。
- 若系统发生回滚的原因为“System software rollback after upgrade, the possible cause is that new version can't register agile controller”,即控制器下发升级失败产生的回滚,请收集告警信息和配置信息,并联系技术支持人员。
V300R022C00SPC100及之后版本支持此原因。
告警清除
此告警需手动清除。