IoT边缘 IoTEdge
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边缘节点离线排查指南
问题描述
在IoTEdge边缘控制台的“边缘节点”>“节点管理页面”,查看节点状态,期望状态是在线,但实际状态为离线。
可能原因
- 安装边缘节点的机器存在网络限制,包括但不限于安全组未放通、系统防火墙限制、路由器拦截等。
- 安装边缘节点的机器底层网络不稳定,存在丢包情况。
排查思路
使用SSH工具以root用户登录边缘节点服务器后台系统,执行如下命令:
- 执行 cat /proc/sys/net/ipv4/ip_forward 。
若值等于0,则需要添加配置IP转发规则。配置方法可以参考注册专业版节点步骤5。
- 对于专业版节点,执行 docker inspect sys-edge-hub | grep cloud_mqtt_server_ip ,获取到设备接入的ip或域名;
对于基础版节点,首先执行ps -ef | grep edge_hub 获取Edgehub的进程id,然后执行 cat /proc/{进程id}/environ | tr '\0' '\n' | grep cloud_mqtt_server_ip 获取到设备接入的ip或域名。
- 执行 curl -kv {ip/域名}:8883 ,如果未显示Connected,需要检查机器是否存在网络限制。
图1 获取IP或域名
- 执行 ping {ip/域名} ,一分钟后中止,观察packet loss是否为0,如果不为0需要联系运营商查看网络不稳定的原因。
图2 packet loss值
父主题: 节点管理