更新时间:2024-01-04 GMT+08:00

ALM-25004 LdapServer数据同步异常(2.x及以前版本)

告警解释

当Manager中LdapServer数据内容不一致时,产生该告警,当两者的数据一致时,对应告警恢复。

当集群中LdapServer与Manager中的LdapServer数据内容不一致时,产生该告警,当两者的数据一致时,对应告警恢复。

告警属性

告警ID

告警级别

可自动清除

25004

致命

告警参数

参数名称

参数含义

ServiceName

产生告警的服务名称。

RoleName

产生告警的角色名称。

HostName

产生告警的主机节点信息。

对系统的影响

LdapServer数据不一致时,有可能是Manager上的LdapServer数据损坏,也有可能是集群上的LdapServer数据损坏,此时数据损坏的LdapServer进程将无法对外提供服务,影响Manager和集群的认证功能。

可能原因

  • LdapServer进程所在的节点网络故障。
  • LdapServer进程异常。
  • OS重启导致的LdapServer数据损坏。

处理步骤

  1. 检查LdapServer所在的节点网络是否故障。

    1. 登录MRS集群详情页面,选择“告警管理”。
    2. 记录该告警定位信息中的“HostName”的IP地址为IP1(若出现多个告警,则分别记录其中的IP地址为IP1、IP2、IP3等)。
    3. 联系运维人员,登录IP1节点,在这个节点上使用ping命令检查该节点与主oms节点的管理平面IP是否可达。
      • 是,执行1.d
      • 否,执行2.a
    4. 联系运维人员恢复网络,然后查看“ALM-25004 LdapServer数据同步异常”告警是否恢复。
      • 是,处理完毕。
      • 否,执行2.a

  2. 检查LdapServer进程是否正常。

    1. 登录MRS集群详情页面,选择“告警管理”。
    2. 查看是否有LdapServer的ALM-12004 OLdap资源异常告警产生。
      • 是,执行2.c
      • 否,执行2.e
    3. 按照ALM-12004 OLdap资源异常提供的步骤处理该告警。
    4. 在告警列表中查看“ALM-25004 LdapServer数据同步异常”告警是否清除。
      • 是,处理完毕。
      • 否,执行2.e
    5. 在MRS Manager的“告警管理”页面,查看是否有LdapServer的ALM-12007 进程故障告警产生。
      • 是,执行2.f
      • 否,执行3.a
    6. 按照ALM-12007 进程故障提供的步骤处理该告警。
    7. 在告警列表中查看“ALM-25004 LdapServer数据同步异常”告警是否清除。
      • 是,处理完毕。
      • 否,执行3.a

  3. 检查是否存在因为OS重启导致LdapServer数据损坏。

    1. 登录MRS集群详情页面,选择“告警管理”。
    2. 记录该告警定位信息中的“HostName”的IP地址为IP1(若出现多个告警,则分别记录其中的IP地址为IP1,IP2,IP3等)。单击“服务管理 > LdapServer > 服务配置”,记录LdapServer的端口号为PORT(若告警定位信息中的IP地址为oms备节点IP地址,则端口号为默认端口21750)。
    3. omm用户登录IP1节点,分别执行ldapsearch -H ldaps://IP1:PORT -x -LLL -b dc=hadoop,dc=com命令(如果该IP为OMS备节点IP地址,执行该命令之前先执行export LDAPCONF=${CONTROLLER_HOME}/ldapserver/ldapserver/local/conf/ldap.conf命令),观察查询出来的内容是否提示有error错误信息。
      • 是,执行3.d
      • 否,执行4
    4. 参考“恢复元数据”章节,使用告警出现日期之前的备份包进行LdapServer恢复和OMS恢复。

      必须使用同一时间点的OMS和LdapServer备份数据进行恢复,否则可能造成业务和操作失败。当业务正常时需要恢复数据,建议手动备份最新管理数据后,再执行恢复数据操作,否则会丢失从备份时刻到恢复时刻之间的Manager数据。

    5. 在告警列表中查看“ALM-25004 LdapServer数据同步异常”告警是否清除。
      • 是,处理完毕。
      • 否,执行4

  4. 收集故障信息。

    1. 在MRS Manager界面,单击“系统设置 > 日志导出”。
    2. 请联系运维人员,并发送已收集的故障日志信息。

参考信息

无。