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更新时间:2024-09-04 GMT+08:00

ALM-12004 OLdap资源异常(2.x及以前版本)

告警解释

当Manager中的Ldap资源异常时,系统产生此告警。

当Manager中的Ldap资源恢复,且告警处理完成时,告警恢复。

告警属性

告警ID

告警级别

可自动清除

12004

严重

告警参数

参数名称

参数含义

ServiceName

产生告警的服务名称。

RoleName

产生告警的角色名称。

HostName

产生告警的主机名。

对系统的影响

OLdap资源异常,Manager认证服务不可用,无法对Web上层服务提供安全认证和用户管理功能,可能引起无法登录Manager。

可能原因

Manager中LdapServer进程故障。

处理步骤

  1. 检查Manager中LdapServer进程是否正常。

    1. 登录主管理节点。
    2. 执行ps -ef | grep slapd,查询配置文件位于“${BIGDATA_HOME}/om-0.0.1/”路径下面的LdapServer资源进程是否正常。

      判断资源正常有两个标识:

      1. 执行sh ${BIGDATA_HOME}/om-0.0.1/sbin/status-oms.sh命令后查看到oldap的“ResHAStatus”为“Normal”。
      2. 执行ps -ef | grep slapd,可以查看到有端口为21750的slapd进程。
      • 是,执行2
      • 否,执行3

  2. 执行kill -2 LdapServer进程pid,等待20秒以后,HA会自动启动Oldap进程。观察当前OLdap资源状态是否正常。

    • 是,操作结束。
    • 否,执行3

  3. 收集故障信息。

    1. 在MRS Manager界面,单击“系统设置 > 日志导出”。
    2. 请联系运维人员,并发送已收集的故障日志信息。

参考信息

无。