更新时间:2025-08-09 GMT+08:00
        
          
          
        
      
      
      
      
      
      
      
      
  
      
      
      
        
ALM-20002 Hue服务不可用(2.x及以前版本)
告警解释
系统按60秒周期性检测Hue服务状态。当Hue服务不可用时产生该告警。
当Hue服务恢复时,告警恢复。
告警属性
| 
         告警ID  | 
       
         告警级别  | 
       
         可自动清除  | 
      
|---|---|---|
| 
         20002  | 
       
         致命  | 
       
         是  | 
      
告警参数
| 
         参数名称  | 
       
         参数含义  | 
      
|---|---|
| 
         ServiceName  | 
       
         产生告警的服务名称。  | 
      
| 
         RoleName  | 
       
         产生告警的角色名称。  | 
      
| 
         HostName  | 
       
         产生告警的主机名。  | 
      
对系统的影响
系统无法提供数据加载,查询,提取服务。
可能原因
- Hue服务所依赖内部服务KrbServer故障。
 - Hue服务所依赖内部服务DBService故障。
 - 与DBService连接的网络异常。
 
处理步骤
检查KrbServer服务是否正常。
- 登录MRS集群详情页面,选择“组件管理”。
 - 在服务列表中查看“KrbServer”的“健康状态”是否为“良好”。
 - 单击KrbServer服务的“操作”列的“重启”,重启该服务。
 - 等待几分钟。检查“ALM-20002 Hue服务不可用”告警是否恢复。
     
     
- 是,处理完毕。
 - 否,执行步骤 5。
 
 
检查DBService是否正常
- 登录MRS集群详情页面,选择“组件管理”。
 - 在服务列表中查看DBService服务健康状态是否为“良好”。
 - 单击DBService服务的“操作”列的“重启”,重启该服务。
     
     
 
      重启服务需要输入MRS Manager管理员密码并勾选“同时重启或启动相关的服务。”。
 - 等待几分钟。检查“ALM-20002 Hue服务不可用”告警是否恢复。
     
     
- 是,操作结束。
 - 否,执行步骤 9。
 
 
检查与DBService连接的网络是否正常。
- 单击“组件管理 > Hue > 实例”,记录主Hue的IP地址。
 - 使用PuTTY工具登录主Hue的IP地址。
 - 执行ping命令,查看主Hue所在主机与DBService服务所在主机的网络连接是否正常。(获取DBService服务IP地址的方式和获取主Hue IP地址的方式相同。)
 - 联系网络管理员恢复网络。
 - 等待几分钟。检查“ALM-20002 Hue服务不可用”告警是否恢复。
     
     
- 是,处理完毕。
 - 否,执行步骤 17。
 
收集故障信息。
 - 在MRS Manager界面,单击“系统设置 > 日志导出”。
 - 在“服务”下拉框中勾选如下节点信息,单击“确定”。
     
     
- Hue
 - Controller
 
 - 设置日志收集的“开始时间”和“结束时间”分别为产生告警的前后10分钟,选择导出类型,单击“确定”,收集对应的故障日志信息。
 
Hue重新启动。
- 单击“组件管理 > Hue”。
 - 选择“更多 > 重启服务”,单击“确定”。
 - 检查该告警是否恢复。
     
     
- 是,处理完毕。
 - 否,执行步骤 20。
 
 
参考信息
无。