更新时间:2024-01-04 GMT+08:00

ALM-12042 关键文件配置异常(2.x及以前版本)

告警解释

系统每隔一个小时检查一次系统中关键的配置是否正确,如果不正常,则上报故障告警。

当检查到配置正确时,则告警恢复。

告警属性

告警ID

告警级别

可自动清除

12042

严重

告警参数

参数名称

参数含义

ServiceName

产生告警的服务名称。

RoleName

产生告警的角色名称。

HostName

产生告警的主机名。

PathName

异常的文件路径或者名称。

对系统的影响

导致文件所属服务功能不正常。

可能原因

用户手动修改了文件配置或者系统异常下电等原因。

处理步骤

  1. 检查异常文件配置。

    1. 登录MRS集群详情页面,选择“告警管理”。
    2. 查看该告警的详细信息,查看定位信息中对应的“HostName”字段值,获取该告警产生的主机名,查看定位信息中对应的“PathName”字段值,获取异常的文件路径或者名称。
    3. 登录告警节点。
    4. 参考信息中查找该文件的检查标准,并对照检查标准对文件进行进一步的手动检查和修改。
    5. 等待一个小时,进入下一次检查,查看告警是否恢复。
      • 是,操作结束。
      • 否,执行2

  2. 收集故障信息。

    1. 在MRS Manager界面,单击“系统设置 > 日志导出”。
    2. 请联系运维人员,并发送已收集的故障日志信息。

参考信息

  • “/etc/fstab”检查文件的检查标准

    检查“/etc/fstab”文件中配置的分区,是否在“/proc/mounts”中能找到,另外再检查在“fstab”中配置的swap分区,是否和“/proc/swaps”一一对应。

  • “/etc/hosts”检查文件的检查标准

    通过命令cat /etc/hosts查看是否存在以下几种情况,如果是,则说明该配置文件配置异常。

    • “/etc/hosts”文件不存在。
    • 该主机的主机名不在文件中配置。
    • 该主机名对应的IP不唯一。
    • 该主机名对应的IP在ipconfig列表中不存在。
    • 该文件中存在一个IP对应多个主机名的情况。