更新时间:2024-12-06 GMT+08:00

ALM-45275 Ranger服务不可用

告警解释

告警模块按180秒周期检测Ranger服务状态,当检测到Ranger服务异常时,系统产生此告警。

当系统检测到Ranger服务恢复正常,且告警处理完成时,告警恢复。

告警属性

告警ID

告警级别

是否自动清除

45275

紧急

告警参数

参数名称

参数含义

来源

产生告警的集群名称。

服务名

产生告警的服务名称。

角色名

产生告警的角色名称。

主机名

产生告警的主机名。

对系统的影响

当Ranger服务不可用时,Ranger无法正常工作,Ranger原生UI无法访问。

可能原因

  • Ranger服务所依赖内部服务DBService故障。
  • RangerAdmin角色实例异常。

处理步骤

检查DBService进程状态。

  1. 在FusionInsight Manager首页,选择“运维 > 告警 > 告警”页面,查看系统是否上报“ALM-27001 DBService服务不可用”告警。

    • 是,执行2
    • 否,执行3

  2. 参考ALM-27001 DBService服务不可用告警帮助指导对DBService服务状态异常进行处理,待DBService告警消除后,查看“Ranger服务不可用”告警是否清除。

    • 是,处理完毕。
    • 否,执行3

检查所有RangerAdmin实例。

  1. omm用户登录RangerAdmin实例所在节点,执行ps -ef|grep "proc_rangeradmin"命令查看当前节点是否存在RangerAdmin进程。

    • 是,执行5
    • 否,重启RangerAdmin故障实例或Ranger服务,执行4

      重启服务期间服务不可用,业务中断。重启实例期间实例不可用,当前实例节点任务会执行失败。

  2. 在告警列表中查看“Ranger服务不可用”告警是否清除。

    • 是,处理完毕。
    • 否,执行5

收集故障信息。

  1. 在FusionInsight Manager界面,选择“运维 > 日志 > 下载”。
  2. 在“服务”框中勾选待操作集群的“Ranger”。
  3. 单击右上角的设置日志收集的“开始时间”和“结束时间”分别为告警产生时间的前后1小时,单击“下载”。
  4. 请联系运维人员,并发送已收集的故障日志信息。

告警清除

此告警修复后,系统会自动清除此告警,无需手工清除。

参考信息

无。