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更新时间:2024-09-04 GMT+08:00

ALM-29010 Impalad 正在提交的查询总数超过阈值

告警解释

以60s为周期检测该Impalad节点正在提交的查询总数,当检测到的数量超过自定义阈值(默认150)时,系统产生此告警。

当系统检测到的数量减少到阈值以下时,告警将自动解除。

告警属性

告警ID

告警级别

是否自动清除

29010

重要

告警参数

类别

参数名称

参数含义

定位信息

来源

产生告警的集群名称

服务名

产生告警的服务名称

角色名

产生告警的角色名称

主机名

产生告警的主机名

附加信息

Trigger Condition

系统当前指标取值满足自定义的告警设置条件

对系统的影响

查询可能会阻塞甚至失败。

可能原因

该Impalad服务维护的查询数量过多,或者阈值设定的太小。

处理步骤

  1. 在FusionInsight Manager首页,选择“运维 > 告警 > 阈值设置 > Impala > 查询任务总数统计 > 提交中的查询总数”,检查阈值大小。

  2. 修改阈值大小。

  3. 选择“实例”页签,勾选所有“Impalad”实例并重启。

    重启全部实例,服务不可用。重启单个实例,会导致当前实例节点正在执行的任务失败,服务可用。

  4. 重启完成后检查告警是否消失。

    • 是,操作结束。
    • 否,执行5

收集故障信息。

  1. 在FusionInsight Manager界面,选择“运维 > 日志 > 下载”。
  2. 在“服务”中勾选待操作集群的“Impala”。
  3. 单击右上角的编辑按钮设置日志收集的“开始时间”和“结束时间”分别为告警产生时间的前后1小时,单击“下载”。
  4. 请联系运维人员,并发送已收集的故障日志信息。

告警清除

此告警修复后,系统会自动清除此告警,无需手工清除。

参考信息