更新时间:2024-10-24 GMT+08:00

ALM-29006 Impalad ODBC连接数超过阈值

告警解释

以30s为周期检测连接到该Impalad节点的客户端连接数,当检测到的连接数超过自定义阈值(默认60)时,系统产生此告警。

当系统检测到客户端连接数减少到阈值以下时,告警将自动解除。

告警属性

告警ID

告警级别

是否自动清除

29006

重要

告警参数

类别

参数名称

参数含义

定位信息

来源

产生告警的集群名称

服务名

产生告警的服务名称

角色名

产生告警的角色名称

主机名

产生告警的主机名

附加信息

Trigger Condition

系统当前指标取值满足自定义的告警设置条件

对系统的影响

后续新建立客户端连接可能会阻塞甚至失败。

可能原因

已经和Impala服务端建立的连接过多,或者阈值设定的太小。

处理步骤

  1. 在FusionInsight Manager首页,选择“运维 > 告警 > 阈值设置 > Impala > 连接数 > 已经连接到Impalad进程的ODBC数量”,检查阈值大小。

  2. 检查连接到当前Impalad进程的ODBC应用数,并关闭闲置的应用,观察告警是否自动清除。

    • 是,处理完毕。
    • 否,执行3,修改并发Impalad支持的并发连接数。

  3. 在FusionInsight Manager首页,选择“集群 > Impala > 配置 > 全部配置 > Impalad > 自定义”,增加自定义参数 --fe_service_threads,该参数默认值64,请按照需要修改该值,单击“保存”按钮保存配置。

  4. 在所有客户端的查询任务都执行完成后,选择“实例”页签,勾选所有“Impalad”实例并重启。

    重启全部实例,服务不可用。重启单个实例,会导致当前实例节点正在执行的任务失败,服务可用。

  5. 重启完成后检查告警是否消失。

    • 是,处理完毕。
    • 否,执行6

收集故障信息。

  1. 在FusionInsight Manager界面,选择“运维 > 日志 > 下载”。
  2. 在“服务”中勾选待操作集群的“Impala”。
  3. 单击右上角的编辑按钮设置日志收集的“开始时间”和“结束时间”分别为告警产生时间的前后1小时,单击“下载”。
  4. 请联系运维人员,并发送已收集的故障日志信息。

告警清除

此告警修复后,系统会自动清除此告警,无需手工清除。

参考信息