更新时间:2024-12-06 GMT+08:00

ALM-14027 DataNode磁盘故障

告警解释

系统每60秒周期性检测DataNode节点上的磁盘状况,当检测到有磁盘出现故障时产生该告警。

当DataNode上故障磁盘都恢复正常后,手动清除该告警,并重启该DataNode。

告警属性

告警ID

告警级别

是否自动清除

14027

重要

告警参数

参数名称

参数含义

来源

产生告警的集群名称。

服务名

产生告警的服务名称。

角色名

产生告警的角色名称。

主机名

产生告警的主机名。

Failed Volumes

故障的磁盘列表。

对系统的影响

上报DataNode磁盘故障告警时,表示该DataNode节点上存在故障的磁盘分区,可能会导致已写入的文件丢失。

可能原因

  • 硬盘故障。
  • 磁盘权限设置不正确。

处理步骤

查看是否存在磁盘告警

  1. 在FusionInsight Manager首页,选择“运维 > 告警 > 告警”查看是否存在告警“ALM-12014 设备分区丢失”或“ALM-12033 慢盘故障”。

    • 是,执行2
    • 否,执行4

  2. 参考ALM-12014 设备分区丢失ALM-12033 慢盘故障告警进行处理,查看对应告警是否清除。

    • 是,执行3
    • 否,执行4

  3. 等待5分钟,检查该告警是否恢复。

    • 是,处理完毕。
    • 否,执行4

修改磁盘权限

  1. 在“运维 > 告警 > 告警”页面,查看该告警的“定位信息”和“附加信息”,获取该告警上报的故障磁盘位置信息。
  2. root用户登录上报告警的节点,进入故障磁盘所在目录,使用ll命令查看该故障磁盘的权限是否711,用户是否为omm

    • 是,执行8
    • 否,执行6

  3. 修改故障磁盘权限,如故障磁盘为data1,则执行以下命令:

    chown omm:wheel data1

    chmod 711 data1

  4. 在Manager告警列表中,单击该告警“操作”列下面的“清除”,手动清除告警。然后选择“集群 > 服务 > HDFS > 实例”勾选该DataNode,选择“更多 > 重启实例”,等待5分钟,查看是否有新的告警上报。

    重启期间服务业务可能受损或中断,建议选择业务低峰期操作。

    • 否,处理完毕。
    • 是,执行8

收集故障信息

  1. 在FusionInsight Manager首页,选择“运维 > 日志 > 下载”。
  2. 在“服务”中勾选待操作集群的“HDFS”和“OMS”。
  3. 单击右上角的设置日志收集的“开始时间”和“结束时间”分别为告警产生时间的前后20分钟,单击“下载”。
  4. 请联系运维人员,并发送已收集的故障日志信息。

告警清除

此告警修复后,系统不会自动清除此告警,需手工清除。

参考信息

无。